aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-01-08 23:33:47 +1300
committerTheo Anderson <telans@posteo.de>2021-01-08 23:33:47 +1300
commitd8d3e2910b8d3317fa491523eb7e39b8be4d5919 (patch)
treee14a0f167199c7841a2cfbc083310252d4284cd0
parentx11-misc/ksnip: Bump to 1.8.0-r1 (diff)
downloadguru-d8d3e291.tar.gz
guru-d8d3e291.tar.bz2
guru-d8d3e291.zip
dev-python/pykeepass: fix pycryptodome imports
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
-rw-r--r--dev-python/pykeepass/pykeepass-3.2.0-r1.ebuild39
-rw-r--r--dev-python/pykeepass/pykeepass-3.2.1-r1.ebuild38
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/pykeepass/pykeepass-3.2.0-r1.ebuild b/dev-python/pykeepass/pykeepass-3.2.0-r1.ebuild
new file mode 100644
index 000000000..c5a9d7a59
--- /dev/null
+++ b/dev-python/pykeepass/pykeepass-3.2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 ) # not all dependency are 3.8 ready
+
+inherit distutils-r1 eutils toolchain-funcs
+
+DESCRIPTION="Python library to interact with keepass databases (supports KDBX3 and KDBX4) "
+HOMEPAGE="https://github.com/libkeepass/pykeepass"
+SRC_URI="https://github.com/libkeepass/pykeepass/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
+ >=dev-python/construct-2.9.4[${PYTHON_USEDEP}]
+ >=dev-python/future-0.17.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/0001-setup.py-exclude-tests-directory.patch" )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # pycryptodomex to pycryptodome conversion
+ sed -i 's/Cryptodome/Crypto/g' pykeepass/kdbx_parsing/{common,twofish}.py || die
+}
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}
diff --git a/dev-python/pykeepass/pykeepass-3.2.1-r1.ebuild b/dev-python/pykeepass/pykeepass-3.2.1-r1.ebuild
new file mode 100644
index 000000000..549ffd7ee
--- /dev/null
+++ b/dev-python/pykeepass/pykeepass-3.2.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to interact with keepass databases (supports KDBX3 and KDBX4) "
+HOMEPAGE="https://github.com/libkeepass/pykeepass"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
+ >=dev-python/construct-2.9.4[${PYTHON_USEDEP}]
+ >=dev-python/future-0.17.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/0001-setup.py-exclude-tests-directory.patch" )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # pycryptodomex to pycryptodome conversion
+ sed -i 's/Cryptodome/Crypto/g' pykeepass/kdbx_parsing/{common,twofish}.py || die
+}
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}