aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-01-18 19:22:41 -0500
committerAisha Tammy <gentoo@aisha.cc>2021-01-18 19:22:50 -0500
commitd8e606a9d2c7f148da3ad3c89d12f8fba1828cc3 (patch)
treef63e9206ca37162ba04863a0da6c1f05adcd2b73
parentdev-python/sysv_ipc: bump to 1.1.0 (diff)
downloadguru-d8e606a9.tar.gz
guru-d8e606a9.tar.bz2
guru-d8e606a9.zip
gui-apps/azote: version bump to 1.8.2
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--gui-apps/azote/Manifest1
-rw-r--r--gui-apps/azote/azote-1.8.2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/gui-apps/azote/Manifest b/gui-apps/azote/Manifest
index ebd938b8f2..c9685fc303 100644
--- a/gui-apps/azote/Manifest
+++ b/gui-apps/azote/Manifest
@@ -1 +1,2 @@
DIST azote-1.8.1.tar.gz 615661 BLAKE2B f742fd037eab1a4ef3d87e1c055b254900151c8006127559cd8188665a01fd5277de4a22da6fd9fad270297fa9f1aab075094e59cc5d21e5ddee4f92bb8be5c5 SHA512 b474718242ab767c50edb6a660c4f2c91378289c6c5ae45e3e1dd37603fa0df56939ad56cf330a6e057edfd9b02f88f0a47b803100ad825dca4da8286214313e
+DIST azote-1.8.2.tar.gz 616189 BLAKE2B a45e1bbd054b409c04f84acb8b67c48bbc33d5efbbc4cdca140e269119e506195e5fb5e59c1b890788190d984ce86f244d8545151c09413841e28d8788c0e038 SHA512 e49cc391801ad8424d0103f5bea0964b0ac20ed66f88b08a78bed1b81ca69b57fcb4674b232a2809c31e1b5af23a4ed0f792ec96def411f2fa2dc2d0f2159337
diff --git a/gui-apps/azote/azote-1.8.2.ebuild b/gui-apps/azote/azote-1.8.2.ebuild
new file mode 100644
index 0000000000..b39da491a0
--- /dev/null
+++ b/gui-apps/azote/azote-1.8.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 desktop
+
+DESCRIPTION="wallpaper manager for wlroots compositors"
+HOMEPAGE="https://github.com/nwg-piotr/azote"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/nwg-piotr/azote"
+else
+ SRC_URI="https://github.com/nwg-piotr/azote/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+IUSE="simple-colorpicker imagemagick wayland X yaml"
+
+RDEPEND="
+ dev-cpp/gtkmm:3.0
+ dev-python/pillow
+ dev-python/pygobject:3=
+ dev-python/send2trash
+ simple-colorpicker? (
+ X? (
+ media-gfx/maim
+ x11-misc/slop
+ )
+ wayland? (
+ gui-apps/grim
+ gui-apps/slurp
+ )
+ )
+ imagemagick? (
+ media-gfx/imagemagick[jpeg,png,svg,X?]
+ )
+ wayland? (
+ gui-apps/swaybg
+ gui-apps/wlr-randr
+ )
+ X? (
+ media-gfx/feh
+ x11-apps/xrandr
+ )
+ yaml? ( dev-python/pyyaml )
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ cd "${S}"
+
+ dobin dist/azote
+ domenu dist/azote.desktop
+
+ insinto /usr/share/azote
+ doins dist/azote.svg dist/indicator_{active,attention}.png
+ insinto /usr/share/licenses/azote
+ doins LICENSE-COLORTHIEF
+}