aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2022-08-30 06:23:33 -0700
committerYuan Liao <liaoyuan@gmail.com>2022-08-30 06:23:33 -0700
commitd95516ac287e2f918accf37bb1ad3ad5a2a0bd92 (patch)
treeaaac4caa76029fe155bd490f3444439680d1bbcf
parentdev-libs/libxlsxwriter: treeclean (diff)
downloadguru-d95516ac.tar.gz
guru-d95516ac.tar.bz2
guru-d95516ac.zip
gnome-extra/extension-manager: Add 0.3.2
Signed-off-by: Yuan Liao <liaoyuan@gmail.com>
-rw-r--r--gnome-extra/extension-manager/Manifest1
-rw-r--r--gnome-extra/extension-manager/extension-manager-0.3.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/gnome-extra/extension-manager/Manifest b/gnome-extra/extension-manager/Manifest
index 763090315..ab273074c 100644
--- a/gnome-extra/extension-manager/Manifest
+++ b/gnome-extra/extension-manager/Manifest
@@ -1 +1,2 @@
DIST extension-manager-0.3.1.tar.gz 1441120 BLAKE2B bd1f6ac1a30521d7ff209c556bcc4ce0103666b9740aa982f0e1a7727b40106df482b693ece920a7449a634955984fa363e217a6b7d14fa0861effe27490824c SHA512 fd434baf0889fcf20a41be71d8bbe6d82aed0baff989747d4da3e8c0ae04a90b6b0b8ad54eede28f266250ca94db8711f35f6a6aa90ceb23195d3460bbd8f1ca
+DIST extension-manager-0.3.2.tar.gz 1447521 BLAKE2B 55d09b54219804c1910a572953d7fee4b8a9131085260db1d4ef014bccf8b13fa2da0a8673c0d78643841d603878183c2b573b084bcd5cb1818721e8194c871b SHA512 84ff2f246d582cdae06a12e5e88309d67ae32502e9885675c08d75dc686fdea28b53bffa37d396ffface8515712f0b990603b5832704ae722342f0ad49748150
diff --git a/gnome-extra/extension-manager/extension-manager-0.3.2.ebuild b/gnome-extra/extension-manager/extension-manager-0.3.2.ebuild
new file mode 100644
index 000000000..a2705683e
--- /dev/null
+++ b/gnome-extra/extension-manager/extension-manager-0.3.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mjakeman/extension-manager.git"
+else
+ SRC_URI="https://github.com/mjakeman/extension-manager/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A native tool for browsing and installing GNOME Shell Extensions"
+HOMEPAGE="https://github.com/mjakeman/extension-manager"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ dev-libs/glib:2
+ dev-util/blueprint-compiler
+ virtual/pkgconfig
+"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ gui-libs/text-engine
+ net-libs/libsoup:3.0
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local emesonargs=()
+ if has live ${PROPERTIES}; then
+ # Produce a development build for live ebuild
+ emesonargs+=( -Ddevelopment=true )
+ fi
+ meson_src_configure
+}
+
+# Tests are skipped because as of version 0.3.0, the tests only validate
+# resource files and do not verify any functionality of the program. Those
+# validations are either already handled by QA checks or not relevant on
+# Gentoo. For more information about the rationale, please refer to:
+# https://github.com/gentoo/guru/commit/f896bee213fbb62c70e818c1bf503fee2a41919a#comments
+#
+# If tests are to be executed in the future because the upstream adds
+# functionality tests or for other reasons, and should there be no convenient
+# way to skip the validations, the following variable values need to be set:
+#
+# IUSE="test"
+# RESTRICT="!test? ( test )"
+# BDEPEND="test? ( dev-libs/appstream-glib dev-util/desktop-file-utils )"
+src_test() {
+ :
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}