aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-01-28 11:09:28 +0100
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-01-28 11:09:50 +0100
commitd9f6a167bf1e31a756ba9b89809291a66d29f216 (patch)
tree1e55148117d6e8077b7dcc22fd9b29db48fd6e63
parentpackage.mask: mask net-wireless/eiwd for removal (diff)
downloadguru-d9f6a167.tar.gz
guru-d9f6a167.tar.bz2
guru-d9f6a167.zip
sys-apps/drm_info: Apply patch for drm_fourcc.h issue
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
-rw-r--r--sys-apps/drm_info/drm_info-2.2.0.ebuild4
-rw-r--r--sys-apps/drm_info/files/drm_info-2.2.0-drm_fourcc-fix.patch29
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/drm_info/drm_info-2.2.0.ebuild b/sys-apps/drm_info/drm_info-2.2.0.ebuild
index bd5c1a2e2a..6b3f11e42d 100644
--- a/sys-apps/drm_info/drm_info-2.2.0.ebuild
+++ b/sys-apps/drm_info/drm_info-2.2.0.ebuild
@@ -19,6 +19,10 @@ HOMEPAGE="https://github.com/ascent12/drm_info"
LICENSE="MIT"
SLOT="0"
+PATCHES=(
+ "${FILESDIR}/${P}-drm_fourcc-fix.patch"
+)
+
DEPEND="
x11-libs/libdrm
dev-libs/json-c:=
diff --git a/sys-apps/drm_info/files/drm_info-2.2.0-drm_fourcc-fix.patch b/sys-apps/drm_info/files/drm_info-2.2.0-drm_fourcc-fix.patch
new file mode 100644
index 0000000000..d5592fd847
--- /dev/null
+++ b/sys-apps/drm_info/files/drm_info-2.2.0-drm_fourcc-fix.patch
@@ -0,0 +1,29 @@
+From 42dad741607d8889f93b2a12725af362c09732a2 Mon Sep 17 00:00:00 2001
+From: Simon Ser <contact@emersion.fr>
+Date: Sun, 10 Jan 2021 12:24:04 +0100
+Subject: [PATCH] Match #define when extracting DRM modifiers
+
+Newer drm_fourcc.h headers have comments which refer to
+DRM_FORMAT_MOD_*. These were matched by the regex.
+
+Fix the regex by requiring a "#define" prefix. I checked that only the
+duplicate values were removed using diff.
+---
+ fourcc.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/fourcc.py b/fourcc.py
+index 23f7be6..ebee1d9 100755
+--- a/fourcc.py
++++ b/fourcc.py
+@@ -22,8 +22,8 @@ def afbc_print(f, l):
+
+ info = {
+ 'fmt': r'^#define (\w+)\s*(?:\\$\s*)?fourcc_code',
+- 'basic_pre': r'\bI915_FORMAT_MOD_\w+\b',
+- 'basic_post': r'\b(DRM_FORMAT_MOD_(?:INVALID|LINEAR|SAMSUNG|QCOM|VIVANTE|NVIDIA|BROADCOM|ALLWINNER)\w*)\s',
++ 'basic_pre': r'^#define (I915_FORMAT_MOD_\w+)\b',
++ 'basic_post': r'^#define (DRM_FORMAT_MOD_(?:INVALID|LINEAR|SAMSUNG|QCOM|VIVANTE|NVIDIA|BROADCOM|ALLWINNER)\w*)\s',
+ 'afbc_block': r'\bAFBC_FORMAT_MOD_BLOCK_SIZE(?:_\d+x\d+)+\b',
+ 'afbc_bitmask': r'\bAFBC_FORMAT_MOD_[A-Z]+\b',
+ }