aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2020-04-13 10:58:32 +0500
committerDenis Reva <denis7774@gmail.com>2020-04-13 10:58:32 +0500
commitda2f2ff2fb892ff97dbe4c16da7635436ea67bc0 (patch)
tree1560e92e605031148448c0ba5e017d63460b142b
parentmedia-plugins/tap-plugins: (diff)
downloadguru-da2f2ff2fb892ff97dbe4c16da7635436ea67bc0.tar.gz
guru-da2f2ff2fb892ff97dbe4c16da7635436ea67bc0.tar.bz2
guru-da2f2ff2fb892ff97dbe4c16da7635436ea67bc0.zip
media-plugins/swh-plugins:
Version bump upon the Gentoo ones with specific GURU fixes Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Denis Reva <denis7774@gmail.com>
-rw-r--r--media-plugins/swh-plugins/Manifest1
-rw-r--r--media-plugins/swh-plugins/files/swh-plugins-0.4.17-system-gsm.patch46
-rw-r--r--media-plugins/swh-plugins/metadata.xml36
-rw-r--r--media-plugins/swh-plugins/swh-plugins-0.4.17.ebuild53
4 files changed, 136 insertions, 0 deletions
diff --git a/media-plugins/swh-plugins/Manifest b/media-plugins/swh-plugins/Manifest
new file mode 100644
index 000000000..7cd7807f6
--- /dev/null
+++ b/media-plugins/swh-plugins/Manifest
@@ -0,0 +1 @@
+DIST swh-plugins-0.4.17.tar.gz 456472 BLAKE2B 827e5c0d6ac692636904df64d1af8d94488f22a26cf09586b0ad32bec9017c9f3cd66074d8f786f5722e4918d32ff27be719561005273f2dcee81ea8690d6274 SHA512 6b566030b43c3929ce8938648abd458efa0fea0b4916410a34b4f4fa788c45e4a6ec3f46ca435f8546179ff0c4674303db22314e1c1f1d09e5f2b71e6c5aecc7
diff --git a/media-plugins/swh-plugins/files/swh-plugins-0.4.17-system-gsm.patch b/media-plugins/swh-plugins/files/swh-plugins-0.4.17-system-gsm.patch
new file mode 100644
index 000000000..f4c1597f5
--- /dev/null
+++ b/media-plugins/swh-plugins/files/swh-plugins-0.4.17-system-gsm.patch
@@ -0,0 +1,46 @@
+diff -Naurd old/configure.ac new/configure.ac
+--- old/configure.ac 2019-03-03 12:10:38.826276038 +0500
++++ new/configure.ac 2019-03-03 21:02:30.456414852 +0500
+@@ -133,17 +133,19 @@
+ AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${datadir}/${PACKAGE}")
+ fi
+
+-subdirs="util gsm gverb metadata"
++GSM_LIBS=-lgsm
++
++subdirs="util gverb metadata"
+
+ AC_SUBST(subdirs)
+ AC_SUBST(FFTW_LIBS)
+ AC_SUBST(STATIC_FFTW_LIBS)
+ AC_SUBST(FFTW_CFLAGS)
++AC_SUBST(GSM_LIBS)
+ AC_SUBST(LIBTOOL)
+ AC_OUTPUT([
+ Makefile
+ util/Makefile
+-gsm/Makefile
+ gverb/Makefile
+ metadata/Makefile
+ po/Makefile.in
+diff -Naurd old/Makefile.am new/Makefile.am
+--- old/Makefile.am 2016-10-17 14:05:54.000000000 +0500
++++ new/Makefile.am 2019-03-03 20:58:55.298862874 +0500
+@@ -34,7 +34,7 @@
+ latency_1914.la xfade_1915.la sc4m_1916.la \
+ mbeq_1197.la pitch_scale_1193.la pitch_scale_1194.la imp_1199.la
+
+-SUBDIRS = po util gsm gverb metadata
++SUBDIRS = po util gverb metadata
+
+ # Wacky stuff to stop automake getting confused
+ EXTRA_DIST = config.rpath @top_srcdir@/*.xml @top_srcdir@/*.c @top_srcdir@/*.h \
+@@ -73,7 +73,7 @@
+ sc4_1882_la_LIBADD = -Lutil -ldb -lrms
+ sc4m_1916_la_LIBADD = -Lutil -ldb -lrms
+ se4_1883_la_LIBADD = -Lutil -ldb -lrms
+-gsm_1215_la_LIBADD = gsm/libgsm.a
++gsm_1215_la_LIBADD = @GSM_LIBS@
+ gverb_1216_la_LIBADD = -Lgverb -lgverb
+ lcr_delay_1436_la_DEPENDENCIES = util/biquad.h
+
diff --git a/media-plugins/swh-plugins/metadata.xml b/media-plugins/swh-plugins/metadata.xml
new file mode 100644
index 000000000..d37b24da8
--- /dev/null
+++ b/media-plugins/swh-plugins/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Denis Reva</name>
+ <description>RarogCmex</description>
+ </maintainer>
+ <longdescription>
+At the moment the only plugins here are for LADSPA, the Linux Audio Developers Plugin API.
+Compiling
+~~~~~~~~~
+You will need libfftw version 2 or 3 installed with 32 bit float support (eg.
+for FFTW3 use --enable-float), for FFTW recommend you specify the appropriate
+SIMD instruction set for your CPU with --enable-sse, --enable-sse2, --enable-k7
+or --enable-altivec. You can get FFTW from http://www.fftw.org/.
+
+This code is normally built from XML source, using Perl and XML::Parser. I
+distribute the generated .c files, so you wont need perl, but if you want to
+edit the XML source then you will need a copy of Perl and XML::Parser
+installed.
+
+Homepage and docs
+~~~~~~~~~~~~~~~~~
+The homepage for this project is http://plugin.org.uk/
+
+Bug reports
+~~~~~~~~~~~
+Please send bug reports or comments to steve@plugin.org.uk, except for bugs
+relating to the gverb plugin, for that please send bug reports etc. to Juhana
+Sadeharju, kouhia_at_nic.funet.fi.
+
+Enjoy,
+ Steve
+ </longdescription>
+</pkgmetadata>
diff --git a/media-plugins/swh-plugins/swh-plugins-0.4.17.ebuild b/media-plugins/swh-plugins/swh-plugins-0.4.17.ebuild
new file mode 100644
index 000000000..00bb4750c
--- /dev/null
+++ b/media-plugins/swh-plugins/swh-plugins-0.4.17.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib-minimal
+
+DESCRIPTION="Large collection of LADSPA audio plugins/effects"
+HOMEPAGE="http://plugin.org.uk"
+SRC_URI="https://github.com/swh/ladspa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="nls cpu_flags_x86_3dnow cpu_flags_x86_sse"
+
+RDEPEND="
+ >=media-sound/gsm-1.0.13-r1[${MULTILIB_USEDEP}]
+ >=sci-libs/fftw-3.3.3-r2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ media-libs/ladspa-sdk
+ sys-devel/gettext"
+BDEPEND="virtual/pkgconfig"
+DOCS=( AUTHORS ChangeLog README TODO )
+S="${WORKDIR}/ladspa-${PV}"
+src_prepare() {
+ eapply_user
+ append-cflags -fPIC -DPIC
+ # Use system libgsm, bug #252890
+ rm -rf gsm
+ eapply "${FILESDIR}/${P}-system-gsm.patch"
+ NOCONFIGURE=1 ./autogen.sh
+ elibtoolize
+ multilib_copy_sources
+}
+multilib_src_configure() {
+ #ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_3dnow 3dnow) \
+ $(use_enable nls) \
+ --enable-fast-install \
+ --disable-dependency-tracking
+}
+pkg_postinst() {
+ ewarn "WARNING: You have to be careful when using the"
+ ewarn "swh plugins. Be sure to lower your sound volume"
+ ewarn "and then play around a bit with the plugins so"
+ ewarn "you get a feeling for it. Otherwise your speakers"
+ ewarn "won't like that."
+ einfo "If you use only 64 bit sequencers, you may want to disable 32 bit support via USE flag"
+ einfo "example| media-plugins/swh-plugins -abi_x86_32"
+}