aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrettalcox <brettalcox@gmail.com>2023-10-05 14:36:32 -0500
committerbrettalcox <brettalcox@gmail.com>2023-10-05 14:36:32 -0500
commitda708e49b67b2aec0cc5bd3496570f915b60a406 (patch)
treef1e1d8cc9f2f30d1d85f1854e638df23e6e44247
parentgui-apps/grimshot: new package, add 9999 (diff)
downloadguru-da708e49.tar.gz
guru-da708e49.tar.bz2
guru-da708e49.zip
net-news/gfeeds: blueprint-compiler
Signed-off-by: brettalcox <brettalcox@gmail.com>
-rw-r--r--net-news/gfeeds/gfeeds-2.2.0.ebuild62
1 files changed, 32 insertions, 30 deletions
diff --git a/net-news/gfeeds/gfeeds-2.2.0.ebuild b/net-news/gfeeds/gfeeds-2.2.0.ebuild
index 53aa0632c..f1cfb7647 100644
--- a/net-news/gfeeds/gfeeds-2.2.0.ebuild
+++ b/net-news/gfeeds/gfeeds-2.2.0.ebuild
@@ -21,51 +21,53 @@ IUSE="debug"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/humanize[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/readability-lxml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- gui-libs/gtk:4
- gui-libs/libadwaita
- net-libs/syndication-domination[python]
- net-libs/webkit-gtk:6
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/readability-lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ dev-util/blueprint-compiler
+ gui-libs/gtk:4
+ gui-libs/libadwaita
+ net-libs/syndication-domination[python]
+ net-libs/webkit-gtk:6
"
RDEPEND="${DEPEND}"
BDEPEND=">=dev-util/meson-0.58"
src_configure() {
- local emesonargs=(
- --buildtype $(usex debug debug release)
- --prefix=/usr
- )
- meson_src_configure
+ local emesonargs=(
+ --buildtype $(usex debug debug release)
+ --prefix=/usr
+ )
+ meson_src_configure
}
src_compile() {
- meson_src_compile
+ meson_src_compile
}
src_install() {
- meson_src_install
- python_fix_shebang "${D}"/usr/bin/gfeeds
+ meson_src_install
+ python_fix_shebang "${D}"/usr/bin/gfeeds
}
pkg_postinst() {
- gnome2_schemas_update
- xdg_icon_cache_update
- xdg_desktop_database_update
+ gnome2_schemas_update
+ xdg_icon_cache_update
+ xdg_desktop_database_update
}
pkg_postrm() {
- gnome2_schemas_update
- xdg_icon_cache_update
- xdg_desktop_database_update
+ gnome2_schemas_update
+ xdg_icon_cache_update
+ xdg_desktop_database_update
}