aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2021-01-01 22:34:23 +0100
committerMaciej Barć <xgqt@protonmail.com>2021-01-01 22:34:25 +0100
commitdb6ce26a2d22b80605beed45ec0e83bcae2df6a5 (patch)
treec9869f7c58f1702908c70d1433f5545a39908e6b
parentx11-misc/betterlockscreen_rapid: fix years of copyright notice (diff)
downloadguru-db6ce26a.tar.gz
guru-db6ce26a.tar.bz2
guru-db6ce26a.zip
x11-misc/gammy: bump to 0.9.60
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com>
-rw-r--r--x11-misc/gammy/Manifest1
-rw-r--r--x11-misc/gammy/gammy-0.9.60.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/gammy/Manifest b/x11-misc/gammy/Manifest
index 7534ccf43..e7f384249 100644
--- a/x11-misc/gammy/Manifest
+++ b/x11-misc/gammy/Manifest
@@ -1,2 +1,3 @@
DIST gammy-0.9.58a.tar.gz 208411 BLAKE2B 1681f5bbe49d8645a5f55be338c82fe6728bd2b643d5cff1343a3c3bc00ba06c7a903a1c4c6d8ca21f1e2e2991ecec79c392f17aeacb75f1b17f0994cc05b1f6 SHA512 fced7b742e15a70933146901dc07c8375bd7fffc6e000e8fa323029366e09d090c9c9c3e5d783fc5ad923259abf798649652af40e1a9bc83f6c60cbb81ee53a8
DIST gammy-0.9.59.tar.gz 209514 BLAKE2B 948bc841361217cde846288e93e67ed944d99fdf682f56a42e85036fe2455ba900f3c80bda712012116280bd2f2a6038f2cb4d783fcc7e2037f2df096c486b6e SHA512 1fd1255f9681b1b59457ad817e604cf73cc81397e927db62d3f53a1c39f7b634544c50931ece71f116f2f01c7fb7d7dc33696e0400fe23785b2a23b112bd8aa5
+DIST gammy-0.9.60.tar.gz 211249 BLAKE2B 00082c1dd7f9dce26b43fa4a3172e7399a4c8c18743c455fec222b33ca55ecb0b2a3d0483f3e83c58843ef6d47a0ceb52ff38185d0e34649fa634b475a845b88 SHA512 2167a14e579575d5d185a62fae93762f30dbb3396a66f99e4affb7ce710f076c119dfe4cd9a2432fd031dcfbe6548b4fbfe91dd854a6152768017c40596209f9
diff --git a/x11-misc/gammy/gammy-0.9.60.ebuild b/x11-misc/gammy/gammy-0.9.60.ebuild
new file mode 100644
index 000000000..4f8a65043
--- /dev/null
+++ b/x11-misc/gammy/gammy-0.9.60.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils qmake-utils xdg
+
+DESCRIPTION="Adaptive screen brightness/temperature"
+HOMEPAGE="https://getgammy.com/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Fushko/${PN}.git"
+else
+ SRC_URI="https://github.com/Fushko/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ x11-libs/libXxf86vm
+"
+DEPEND="
+ ${RDEPEND}
+ media-gfx/imagemagick
+"
+
+src_configure() {
+ eqmake5 PREFIX="${D}/usr"
+}
+
+src_install() {
+ default
+
+ local sizes="
+ 128
+ 16
+ 32
+ 64
+ "
+ cd ./icons || die
+ for size in ${sizes}; do
+ convert "${size}x${size}ball.ico" "${size}x${size}ball.png" || die
+ newicon -s "${size}" "${size}x${size}ball.png" "${PN}.png"
+ done
+
+ make_desktop_entry "${PN}" "${PN^}" "${PN}" "Graphics;Settings"
+}