aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:11:27 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-03-29 11:29:02 +0200
commitde89d7e0f74414f4b254c4f6ea091cf16c0744e4 (patch)
treefc1063de42b6a452b9009f48989a142c9cd8db78
parentdev-python/pytest-instafail: new package (diff)
downloadguru-de89d7e0.tar.gz
guru-de89d7e0.tar.bz2
guru-de89d7e0.zip
dev-python/pytest-travis-fold: new package
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/pytest-travis-fold/Manifest1
-rw-r--r--dev-python/pytest-travis-fold/metadata.xml13
-rw-r--r--dev-python/pytest-travis-fold/pytest-travis-fold-1.3.0.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-travis-fold/Manifest b/dev-python/pytest-travis-fold/Manifest
new file mode 100644
index 0000000000..e078951d96
--- /dev/null
+++ b/dev-python/pytest-travis-fold/Manifest
@@ -0,0 +1 @@
+DIST pytest-travis-fold-1.3.0.tar.gz 7787 BLAKE2B 1ccecca18312d85b4bec0fcd6398a4b8aa19053c18799eb5bd4bb59a1e33e5eaa45bb952e4f3b356ba985cb81ef4753c474ebbfd901d57bce8e8521f16541768 SHA512 18b551690a526330a7ed3846c4ecb123e5ecbd6edb91ba145525b48391c5226b6e5ff44ba4e5c46487ca3716120a2d0d0518c2ef4cab5ee3419496124a5f2ffa
diff --git a/dev-python/pytest-travis-fold/metadata.xml b/dev-python/pytest-travis-fold/metadata.xml
new file mode 100644
index 0000000000..ec09803fab
--- /dev/null
+++ b/dev-python/pytest-travis-fold/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">abusalimov/pytest-travis-fold</remote-id>
+ <remote-id type="pypi">pytest-travis-fold</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-travis-fold/pytest-travis-fold-1.3.0.ebuild b/dev-python/pytest-travis-fold/pytest-travis-fold-1.3.0.ebuild
new file mode 100644
index 0000000000..98822960b9
--- /dev/null
+++ b/dev-python/pytest-travis-fold/pytest-travis-fold-1.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin that folds captured output sections in Travis CI build log"
+HOMEPAGE="
+ https://github.com/abusalimov/pytest-travis-fold
+ https://pypi.org/project/pytest-travis-fold
+"
+SRC_URI="https://github.com/abusalimov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]
+ <dev-python/pytest-4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest