aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-02-14 20:56:42 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-05 02:34:28 +0100
commite1a9c01dff9ffc38041eae1f9985772a2f718497 (patch)
treebaaf7b357e660ace1cb536a908f43b01b14a4ee4
parentsys-apps/ov: initial import (diff)
downloadguru-e1a9c01d.tar.gz
guru-e1a9c01d.tar.bz2
guru-e1a9c01d.zip
sys-cluster/shuffile: check for /dev/shm
Bug: 784647 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sys-cluster/shuffile/shuffile-0.1.0-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-cluster/shuffile/shuffile-0.1.0-r1.ebuild b/sys-cluster/shuffile/shuffile-0.1.0-r1.ebuild
new file mode 100644
index 000000000..da4689e0e
--- /dev/null
+++ b/sys-cluster/shuffile/shuffile-0.1.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="SHUFFILE Shuffle files between processes"
+HOMEPAGE="https://github.com/ECP-VeloC/shuffile"
+SRC_URI="https://github.com/ECP-VeloC/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=sys-cluster/KVTree-1.0.2[mpi]
+ sys-libs/zlib
+ virtual/mpi
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-util/cmake-2.8
+"
+
+PATCHES=( "${FILESDIR}/${P}-no-static.patch" )
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DENABLE_TESTS=$(usex test)
+ -DSHUFFILE_LINK_STATIC=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ if mountpoint -q /dev/shm ; then
+ cmake_src_test
+ else
+ eerror "make sure to mount /dev/shm or tests will fail"
+ die
+ fi
+}