aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Beddek <telans@posteo.de>2022-06-08 17:06:43 +1200
committerJames Beddek <telans@posteo.de>2022-06-08 17:13:45 +1200
commite2b1247ef79a30485fe7f313a0d5a9f7549c262a (patch)
tree4c35cceb11dd44fe88b6a6e2f4527b6ed26c897a
parentdev-python/marshmallow_enum: new package, add 1.5.1 (diff)
downloadguru-e2b1247e.tar.gz
guru-e2b1247e.tar.bz2
guru-e2b1247e.zip
dev-python/hypothesmith: new package, add 0.2.0
Signed-off-by: James Beddek <telans@posteo.de>
-rw-r--r--dev-python/hypothesmith/Manifest1
-rw-r--r--dev-python/hypothesmith/hypothesmith-0.2.0.ebuild47
-rw-r--r--dev-python/hypothesmith/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/hypothesmith/Manifest b/dev-python/hypothesmith/Manifest
new file mode 100644
index 000000000..37e577843
--- /dev/null
+++ b/dev-python/hypothesmith/Manifest
@@ -0,0 +1 @@
+DIST hypothesmith-0.2.0.tar.gz 24933 BLAKE2B 36c5296d2ab5d86a2dcde565bda16aff31de7f0be1cbc487ea2115e6e3baacf5ba740192885dd5a843d53c51932551574c0debd97f1b374a4e0bea48ec4204d4 SHA512 b82627897f0e07e6249ce2d3730134690dbe340b81632a1101b6b6b9a9ac6ccd0f350ba10f729349ef200b9243081f7f58eb760ccbcb4175adfcc5f411a8a045
diff --git a/dev-python/hypothesmith/hypothesmith-0.2.0.ebuild b/dev-python/hypothesmith/hypothesmith-0.2.0.ebuild
new file mode 100644
index 000000000..98bb73f53
--- /dev/null
+++ b/dev-python/hypothesmith/hypothesmith-0.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} ) # python3_11 depends on dev-python/libcst
+
+inherit distutils-r1
+
+DESCRIPTION="Hypothesis strategies for generating Python programs"
+HOMEPAGE="https://github.com/Zac-HD/hypothesmith"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ sed -e '/-Werror/d' \
+ -e '/--cov/d' \
+ -i tox.ini || die
+}
+
+RDEPEND="
+ >=dev-python/hypothesis-5.41.0[${PYTHON_USEDEP}]
+ >=dev-python/lark-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/libcst-0.3.8[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/parso[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ # https://github.com/Zac-HD/hypothesmith/issues/21
+ local EPYTEST_DESELECT=( 'tests/test_cst.py::test_source_code_from_libcst_node_type' )
+ epytest
+}
diff --git a/dev-python/hypothesmith/metadata.xml b/dev-python/hypothesmith/metadata.xml
new file mode 100644
index 000000000..2924f0387
--- /dev/null
+++ b/dev-python/hypothesmith/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>telans@posteo.de</email>
+ <name>James Beddek</name>
+ </maintainer>
+</pkgmetadata>