aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber+gentoo@sysrq.in>2021-05-25 07:17:37 +0500
committerAnna Vyalkova <cyber+gentoo@sysrq.in>2021-05-25 13:06:54 +0500
commite2d4a9336d65d81c919367a9e490d381ca9cec7a (patch)
tree6cf12ca9fbf1d68fb34c2f10efd76b05bda7de67
parentdev-python/geopy: fix deps, rework tests, drop old (diff)
downloadguru-e2d4a933.tar.gz
guru-e2d4a933.tar.bz2
guru-e2d4a933.zip
www-client/woob: fixes in deps, add docs
Signed-off-by: Anna Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--www-client/woob/Manifest2
-rw-r--r--www-client/woob/woob-3.0-r1.ebuild (renamed from www-client/woob/woob-3.0.ebuild)40
-rw-r--r--www-client/woob/woob-9999.ebuild40
3 files changed, 25 insertions, 57 deletions
diff --git a/www-client/woob/Manifest b/www-client/woob/Manifest
index c653ec8b73..babc31bee4 100644
--- a/www-client/woob/Manifest
+++ b/www-client/woob/Manifest
@@ -1 +1 @@
-DIST woob-3.0.tar.gz 1037459 BLAKE2B 989af820505d8bd32318f87a49bb8106224ee88655f1339baee95782894aca5fd3a95fc9d80a643cf0db27d542a4b61ac9c0b50e47b69e68cd1132d229a84743 SHA512 1147330ee6801a250fa22d15640d8ba7dac7e26be41e05a5f6b33c8f61967f32a94eedd74ec70bdfade3a3766312ccff5f09baefb76f45416d3d92185ff6265f
+DIST woob-3.0.tar.gz 3122974 BLAKE2B 0faff4d917674496f3340465e176641d74e0c86e9c29350aaba1ee864a7477b504812b88144bf63c06c7515762916c971916fb59f720d0380de08d85f1c17b7b SHA512 bf4bb0bd7fd1643b867b03a78f59675c1ea0b8d4455883726d0803a3ed13d37c64795e2a98e8d580852650f6853809356955f583aac37cc6b8e08818b2f3abf1
diff --git a/www-client/woob/woob-3.0.ebuild b/www-client/woob/woob-3.0-r1.ebuild
index dbed431d45..b0535df1d6 100644
--- a/www-client/woob/woob-3.0.ebuild
+++ b/www-client/woob/woob-3.0-r1.ebuild
@@ -3,29 +3,26 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
if [[ "${PV}" == "9999" ]]
then
- EGIT_REPO_URI="https://gitlab.com/woob/woob.git"
+ EGIT_REPO_URI="https://gitlab.com/${PN}/${PN}.git"
inherit git-r3
else
- SRC_URI="https://gitlab.com/woob/woob/uploads/98647f26717896697b52170cf8bcd301/${P}.tar.gz"
+ SRC_URI="https://gitlab.com/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
fi
DESCRIPTION="Web Outside Of Browsers (core, site modules and applications)"
-HOMEPAGE="https://woob.tech/"
+HOMEPAGE="https://woob.tech https://gitlab.com/woob/woob"
LICENSE="LGPL-3+"
SLOT="0"
-IUSE="test"
-#RESTRICT="!test ( test )"
-# setup.cfg + .ci/requirements.txt + .ci/requirements-module.txt
-COMMON_DEPEND="
+RDEPEND="
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/cssselect[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
@@ -37,33 +34,20 @@ COMMON_DEPEND="
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/geopy[${PYTHON_USEDEP}]
dev-python/prettytable[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
dev-python/unidecode[${PYTHON_USEDEP}]
"
-# setup.cfg + .ci/requirements.txt + .ci/requirements-module.txt
-DEPEND="
- ${COMMON_DEPEND}
- test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/xunitparser[${PYTHON_USEDEP}]
- >=dev-python/coverage-5.1[${PYTHON_USEDEP}]
-
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/asttokens[${PYTHON_USEDEP}]
-
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/python-jose[${PYTHON_USEDEP}]
- dev-python/geopy[${PYTHON_USEDEP}]
- dev-python/selenium[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${COMMON_DEPEND}"
+DEPEND="${RDEPEND}"
distutils_enable_tests nose
+distutils_enable_sphinx docs/source
+
src_prepare() {
default
diff --git a/www-client/woob/woob-9999.ebuild b/www-client/woob/woob-9999.ebuild
index dbed431d45..b0535df1d6 100644
--- a/www-client/woob/woob-9999.ebuild
+++ b/www-client/woob/woob-9999.ebuild
@@ -3,29 +3,26 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
if [[ "${PV}" == "9999" ]]
then
- EGIT_REPO_URI="https://gitlab.com/woob/woob.git"
+ EGIT_REPO_URI="https://gitlab.com/${PN}/${PN}.git"
inherit git-r3
else
- SRC_URI="https://gitlab.com/woob/woob/uploads/98647f26717896697b52170cf8bcd301/${P}.tar.gz"
+ SRC_URI="https://gitlab.com/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
fi
DESCRIPTION="Web Outside Of Browsers (core, site modules and applications)"
-HOMEPAGE="https://woob.tech/"
+HOMEPAGE="https://woob.tech https://gitlab.com/woob/woob"
LICENSE="LGPL-3+"
SLOT="0"
-IUSE="test"
-#RESTRICT="!test ( test )"
-# setup.cfg + .ci/requirements.txt + .ci/requirements-module.txt
-COMMON_DEPEND="
+RDEPEND="
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/cssselect[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
@@ -37,33 +34,20 @@ COMMON_DEPEND="
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/geopy[${PYTHON_USEDEP}]
dev-python/prettytable[${PYTHON_USEDEP}]
- dev-python/future[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
dev-python/unidecode[${PYTHON_USEDEP}]
"
-# setup.cfg + .ci/requirements.txt + .ci/requirements-module.txt
-DEPEND="
- ${COMMON_DEPEND}
- test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/xunitparser[${PYTHON_USEDEP}]
- >=dev-python/coverage-5.1[${PYTHON_USEDEP}]
-
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pyflakes[${PYTHON_USEDEP}]
- dev-python/asttokens[${PYTHON_USEDEP}]
-
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/python-jose[${PYTHON_USEDEP}]
- dev-python/geopy[${PYTHON_USEDEP}]
- dev-python/selenium[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${COMMON_DEPEND}"
+DEPEND="${RDEPEND}"
distutils_enable_tests nose
+distutils_enable_sphinx docs/source
+
src_prepare() {
default