aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Greener <dev@greener.sh>2024-04-18 20:23:34 +0100
committerRobert Greener <dev@greener.sh>2024-04-18 20:25:23 +0100
commite4ab7e60590fe3cdf6da809b5fd748e9ac5c176b (patch)
tree613eca9d228c6b6c39605cb60dd66c230dc18bda
parentdev-java/corretto-bin: version 17.0.10.8.1 fix QA issues (diff)
downloadguru-e4ab7e60.tar.gz
guru-e4ab7e60.tar.bz2
guru-e4ab7e60.zip
dev-java/corretto-bin: version 21.0.2.14.1 fix QA issues
Signed-off-by: Robert Greener <dev@greener.sh>
-rw-r--r--dev-java/corretto-bin/corretto-bin-21.0.2.14.1.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-java/corretto-bin/corretto-bin-21.0.2.14.1.ebuild b/dev-java/corretto-bin/corretto-bin-21.0.2.14.1.ebuild
index 8305000c24..3a3a6a4a09 100644
--- a/dev-java/corretto-bin/corretto-bin-21.0.2.14.1.ebuild
+++ b/dev-java/corretto-bin/corretto-bin-21.0.2.14.1.ebuild
@@ -6,15 +6,16 @@ EAPI=8
inherit java-vm-2 toolchain-funcs
MY_PV=${PV/_p/+}
-SLOT=$(ver_cut 1)
+DESCRIPTION="Prebuilt Java JDK binaries provided by Amazon Web Services"
+HOMEPAGE="https://aws.amazon.com/corretto"
SRC_URI="
- https://corretto.aws/downloads/resources/${PV}/amazon-corretto-${PV}-linux-x64.tar.gz
+ https://corretto.aws/downloads/resources/${PV}/amazon-corretto-${PV}-linux-x64.tar.gz
"
-DESCRIPTION="Prebuilt Java JDK binaries provided by Amazon Web Services"
-HOMEPAGE="https://aws.amazon.com/corretto"
+S="${WORKDIR}/amazon-corretto-${MY_PV}-linux-x64"
LICENSE="GPL-2-with-classpath-exception"
+SLOT=$(ver_cut 1)
KEYWORDS="~amd64"
IUSE="alsa cups headless-awt selinux source"
@@ -42,8 +43,6 @@ RDEPEND="
RESTRICT="preserve-libs splitdebug"
QA_PREBUILT="*"
-S="${WORKDIR}/amazon-corretto-${MY_PV}-linux-x64"
-
pkg_pretend() {
if [[ "$(tc-is-softfloat)" != "no" ]]; then
die "These binaries require a hardfloat system."
@@ -88,4 +87,4 @@ src_install() {
pkg_postinst() {
java-vm-2_pkg_postinst
-} \ No newline at end of file
+}