aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-03 18:43:03 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-03 20:32:01 +0200
commite4b77eb4a4ef30ac50c233fe39287de6f1092c2d (patch)
treeb7012e7dfe917caf2c2a3bbfb3718b5c69d03872
parentdev-python/jsonpath-rw-ext: initial import (diff)
downloadguru-e4b77eb4.tar.gz
guru-e4b77eb4.tar.bz2
guru-e4b77eb4.zip
dev-python/wsgi_intercept: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/wsgi_intercept/Manifest1
-rw-r--r--dev-python/wsgi_intercept/metadata.xml11
-rw-r--r--dev-python/wsgi_intercept/wsgi_intercept-1.9.2.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/wsgi_intercept/Manifest b/dev-python/wsgi_intercept/Manifest
new file mode 100644
index 000000000..3c3189d40
--- /dev/null
+++ b/dev-python/wsgi_intercept/Manifest
@@ -0,0 +1 @@
+DIST wsgi_intercept-1.9.2.tar.gz 29083 BLAKE2B 97eda40f40f0ea00ff213f2222310ce6c77ee9c822e89330ed8a277f32851d06bdf1050629e69677cf7fb00d04128403c5a89aec1d03d796fdbb65e8f3e4e9b6 SHA512 a313fe6302c9f168bd050c83ded1d58ef74feb54870197eb85b3527c2cc77eb76b4ca61ff4b554e13cca10ec7106ad9ba35c9a41a00bbd82ef39a26df2af7769
diff --git a/dev-python/wsgi_intercept/metadata.xml b/dev-python/wsgi_intercept/metadata.xml
new file mode 100644
index 000000000..5796baec0
--- /dev/null
+++ b/dev-python/wsgi_intercept/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">wsgi-intercept</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wsgi_intercept/wsgi_intercept-1.9.2.ebuild b/dev-python/wsgi_intercept/wsgi_intercept-1.9.2.ebuild
new file mode 100644
index 000000000..8e7984886
--- /dev/null
+++ b/dev-python/wsgi_intercept/wsgi_intercept-1.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="wsgi_intercept installs a WSGI application in place of a real URI for testing"
+HOMEPAGE="https://pypi.org/project/wsgi-intercept"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest