aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-31 11:05:48 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-05-31 12:26:46 +0500
commite5619f452d0da7a3595dc6846de62f6ec3888640 (patch)
treee6256ce4c73a1905ecd1018abc924a38cd6ff81e
parentdev-libs/libcloudproviders: update EAPI 7 -> 8 (diff)
downloadguru-e5619f45.tar.gz
guru-e5619f45.tar.bz2
guru-e5619f45.zip
games-board/openriichi: update EAPI 7 -> 8
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--games-board/openriichi/openriichi-0.2.1.1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/games-board/openriichi/openriichi-0.2.1.1.ebuild b/games-board/openriichi/openriichi-0.2.1.1.ebuild
index 4e745a705..a56bc710d 100644
--- a/games-board/openriichi/openriichi-0.2.1.1.ebuild
+++ b/games-board/openriichi/openriichi-0.2.1.1.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-VALA_MIN_API_VERSION="0.44"
+EAPI=8
inherit desktop meson vala xdg
@@ -16,15 +14,12 @@ SRC_URI="
https://github.com/FluffyStuff/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://github.com/FluffyStuff/Engine/archive/${Engine_sha}.tar.gz -> ${P}-Engine.tar.gz
"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="mirror"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
RDEPEND="
$(vala_depend)
dev-libs/libgee:0.8
@@ -45,12 +40,12 @@ src_prepare() {
#switch vsync ON by default
sed -i -e "s/v_sync = OnOffEnum.OFF/v_sync = OnOffEnum.ON/" "${S}/source/Game/Options.vala" || die
- vala_src_prepare
+ vala_setup
}
src_install() {
meson_src_install
newicon -s 64 "bin/Data/Icon.png" "${MY_PN}.png"
- make_desktop_entry "${MY_PN}" "${MY_PN}" "${MY_PN}" "Game;BoardGame" || die "Failed making desktop entry!"
+ make_desktop_entry "${MY_PN}" "${MY_PN}" "${MY_PN}" "Game;BoardGame"
}