aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-10 05:24:53 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-07-10 05:25:45 +0200
commite59766d278e664344b81c8c49f2b9ef8b52376ae (patch)
tree9350500776ca5722f534485e0fd89d879d4b435e
parentdev-python/uharfbuzz: fix build failure (diff)
downloadguru-e59766d2.tar.gz
guru-e59766d2.tar.bz2
guru-e59766d2.zip
dev-python/vharfbuzz: fix package_dir
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-python/vharfbuzz/files/vharfbuzz-0.1.1-fix-package-dir.patch11
-rw-r--r--dev-python/vharfbuzz/vharfbuzz-0.1.1.ebuild2
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-python/vharfbuzz/files/vharfbuzz-0.1.1-fix-package-dir.patch b/dev-python/vharfbuzz/files/vharfbuzz-0.1.1-fix-package-dir.patch
new file mode 100644
index 000000000..7a4693959
--- /dev/null
+++ b/dev-python/vharfbuzz/files/vharfbuzz-0.1.1-fix-package-dir.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -29,7 +29,7 @@
+ "Development Status :: 4 - Beta"
+
+ ],
+- 'package_dir': {'':'Lib'},
++ 'package_dir': {'':'lib'},
+ 'packages': ["vharfbuzz"]
+ ,
+ }
diff --git a/dev-python/vharfbuzz/vharfbuzz-0.1.1.ebuild b/dev-python/vharfbuzz/vharfbuzz-0.1.1.ebuild
index 2f638053f..ccd729de8 100644
--- a/dev-python/vharfbuzz/vharfbuzz-0.1.1.ebuild
+++ b/dev-python/vharfbuzz/vharfbuzz-0.1.1.ebuild
@@ -21,4 +21,6 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${P}-fix-package-dir.patch" )
+
distutils_enable_sphinx docs dev-python/sphinxcontrib-napoleon