aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-30 21:12:50 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-30 21:12:50 +0200
commite7643c7ed7a8d7812fa416fd828666d126861590 (patch)
tree38b0c56890be7ce706bd5f17bc52bf50177f708b
parentmetadata/layout.conf: re-add layout.conf, please don't delete this (diff)
downloadguru-e7643c7ed7a8d7812fa416fd828666d126861590.tar.gz
guru-e7643c7ed7a8d7812fa416fd828666d126861590.tar.bz2
guru-e7643c7ed7a8d7812fa416fd828666d126861590.zip
sci-libs/jdqz: fix tests
had to depend on [deprecated] on lapack Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--sci-libs/jdqz/jdqz-1997.11.07.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sci-libs/jdqz/jdqz-1997.11.07.ebuild b/sci-libs/jdqz/jdqz-1997.11.07.ebuild
index b2530c7f7..054ae05ef 100644
--- a/sci-libs/jdqz/jdqz-1997.11.07.ebuild
+++ b/sci-libs/jdqz/jdqz-1997.11.07.ebuild
@@ -15,13 +15,11 @@ KEYWORDS="~amd64"
IUSE="doc"
-# /usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: ../jdlib/libjdqz.so: undefined reference to `zgegs_'
-#/usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: ../jdlib/libjdqz.so: undefined reference to `zgegv_'
-RESTRICT="test"
-
+# vvirtual/lapack does not pull in [deprecated] so we have to deal with this mess like this until it does
DEPEND="
virtual/blas
virtual/lapack
+ || ( sci-libs/openblas sci-libs/lapack[deprecated] )
"
RDEPEND="${DEPEND}"
BDEPEND="doc? ( dev-texlive/texlive-latex )"
@@ -59,8 +57,9 @@ src_compile() {
}
src_test() {
- cd jdtest || die
+ cd "jdtest" || die
emake
+ cd ".." || die
LD_LIBRARY_PATH="./jdlib" ./jdtest/example || die
}