aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall T. Vasquez <ran.dall@icloud.com>2022-07-30 09:27:57 -0700
committerRandall T. Vasquez <ran.dall@icloud.com>2022-07-30 09:29:37 -0700
commite86df47ed839b988490678e24b472e666d6d400a (patch)
tree925959109cfabb4c81540764c21f3d7865a63cca
parentdev-util/blueprint-compiler: Drop 0.1.0_pre20220419 (diff)
downloadguru-e86df47e.tar.gz
guru-e86df47e.tar.bz2
guru-e86df47e.zip
dev-util/shfmt: drop ebuilds
`dev-util/sh` is now available in ::gentoo Signed-off-by: Randall T. Vasquez <ran.dall@icloud.com>
-rw-r--r--dev-util/shfmt/Manifest2
-rw-r--r--dev-util/shfmt/metadata.xml14
-rw-r--r--dev-util/shfmt/shfmt-3.5.1.ebuild50
-rw-r--r--dev-util/shfmt/shfmt-9999.ebuild50
4 files changed, 0 insertions, 116 deletions
diff --git a/dev-util/shfmt/Manifest b/dev-util/shfmt/Manifest
deleted file mode 100644
index 5363e0a6e4..0000000000
--- a/dev-util/shfmt/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST shfmt-3.5.1-deps.tar.xz 3117092 BLAKE2B 13e85d2b737f80f1c90201e7d035fb01bb624e396ccf292d00e5c8c19da8209c69ecff88ce334ba0de8e7bbf4243be58cbcea21ee99166285f2738f0036862c9 SHA512 24791e7798fdfe69e76117785b5d469742f680c2ed7d186cb580e55776e5e011ab907be882f6394b9f84f82717611a28f9e72ec5280d6a9d7e89f629bb4a378a
-DIST shfmt-3.5.1.tar.gz 222608 BLAKE2B a81af092d0f8d0ee7c05240d816a99f044bce3e35d242a815a238a27893db5bfc320efc4a0237ca9ecfa0276e4687152c87f6e0170f5326e2d0a8604f94f6adb SHA512 fd1084921254b70376b3ac47b97e2108308252fa6bd23aff1e59aaefb45a7e01c1738a46ae6f4eb255ecade77fb9659fbc8184d2473e8e4f70e520757bad506d
diff --git a/dev-util/shfmt/metadata.xml b/dev-util/shfmt/metadata.xml
deleted file mode 100644
index 8980314683..0000000000
--- a/dev-util/shfmt/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>ran.dall@icloud.com</email>
- <name>Randall Vasquez</name>
- </maintainer>
- <longdescription lang="en">
- A shell parser, formatter, and interpreter with bash support; includes shfmt. Supports POSIX Shell, Bash, and mksh.
- </longdescription>
- <upstream>
- <remote-id type="github">mvdan/sh</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-util/shfmt/shfmt-3.5.1.ebuild b/dev-util/shfmt/shfmt-3.5.1.ebuild
deleted file mode 100644
index 96a20587ac..0000000000
--- a/dev-util/shfmt/shfmt-3.5.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="Shell script formatter"
-HOMEPAGE="https://github.com/mvdan/sh"
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mvdan/sh.git"
- RESTRICT="fetch mirror test"
-else
- SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://github.com/ran-dall/portage-deps/raw/master/${P}-deps.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~x86"
- RESTRICT="mirror test"
- S="${WORKDIR}/${PN//fmt}-${PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+man"
-
-BDEPEND="man? ( app-text/scdoc )"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999 ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- else
- go-module_src_unpack
- fi
-}
-
-src_compile() {
- ego build -v -ldflags "-s -w" -o "${PN}" "./cmd/shfmt"
- if use man; then
- scdoc < cmd/shfmt/shfmt.1.scd > shfmt.1 || die "conversation of man page failed"
- fi
-}
-
-src_install() {
- dobin ${PN}
- if use man; then
- doman shfmt.1
- fi
-}
diff --git a/dev-util/shfmt/shfmt-9999.ebuild b/dev-util/shfmt/shfmt-9999.ebuild
deleted file mode 100644
index 96a20587ac..0000000000
--- a/dev-util/shfmt/shfmt-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module
-
-DESCRIPTION="Shell script formatter"
-HOMEPAGE="https://github.com/mvdan/sh"
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mvdan/sh.git"
- RESTRICT="fetch mirror test"
-else
- SRC_URI="https://github.com/mvdan/sh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://github.com/ran-dall/portage-deps/raw/master/${P}-deps.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~x86"
- RESTRICT="mirror test"
- S="${WORKDIR}/${PN//fmt}-${PV}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+man"
-
-BDEPEND="man? ( app-text/scdoc )"
-
-src_unpack() {
- default
- if [[ ${PV} == *9999 ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- else
- go-module_src_unpack
- fi
-}
-
-src_compile() {
- ego build -v -ldflags "-s -w" -o "${PN}" "./cmd/shfmt"
- if use man; then
- scdoc < cmd/shfmt/shfmt.1.scd > shfmt.1 || die "conversation of man page failed"
- fi
-}
-
-src_install() {
- dobin ${PN}
- if use man; then
- doman shfmt.1
- fi
-}