aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-05 22:48:35 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-10-05 22:50:53 +0200
commitea36a61dd9bf58eee20c8d16fb0e4dbae4903442 (patch)
tree6e2ae21c081c36cba49cf708a41257ff05e43600
parentdev-cpp/wangle: add 2021.10.04.00 (diff)
downloadguru-ea36a61d.tar.gz
guru-ea36a61d.tar.bz2
guru-ea36a61d.zip
dev-cpp/fbthrift: add 2021.10.04.00
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--dev-cpp/fbthrift/Manifest1
-rw-r--r--dev-cpp/fbthrift/fbthrift-2021.10.04.00.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/fbthrift/Manifest b/dev-cpp/fbthrift/Manifest
index dcd8c044f..01b0015b5 100644
--- a/dev-cpp/fbthrift/Manifest
+++ b/dev-cpp/fbthrift/Manifest
@@ -1 +1,2 @@
DIST fbthrift-2021.08.02.00.tar.gz 5833339 BLAKE2B 647f582396a88ae616162e011bc77c15d4e08d0b511f12684d4b731a2108c370971d7ec52f8ac0c84ff9e94b228e69f4fca29b1ca0747e39bbcf5d58cd491b2a SHA512 a416f9a09a62293fc756d631355787fd0faed639d77986a654610c3fc49344e1f0184d2333c79bd49ac9a450be6d2542317beb512e72d99179206db0cc5e7467
+DIST fbthrift-2021.10.04.00.tar.gz 5974931 BLAKE2B f268dae6368c8619d877d41bf4eaa018110e002da6b5a57a573d3345da62d5dfc13310e84792ad59d3c9e11e70e67eced7b441bfad67fe23afe1a779e485030c SHA512 5b1c7f2e787d198bcf8664e38714e860fbeda75aa1c2cd35e6dde10493451d58241693c81fbf7680725747e9ccb958728dc1ed27d161c466ee18e00ca2d25b2f
diff --git a/dev-cpp/fbthrift/fbthrift-2021.10.04.00.ebuild b/dev-cpp/fbthrift/fbthrift-2021.10.04.00.ebuild
new file mode 100644
index 000000000..3320d823e
--- /dev/null
+++ b/dev-cpp/fbthrift/fbthrift-2021.10.04.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Facebook's branch of Apache Thrift, including a new C++ server"
+HOMEPAGE="https://github.com/facebook/fbthrift"
+SRC_URI="https://github.com/facebook/fbthrift/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-arch/zstd
+ ~dev-cpp/fizz-${PV}:=
+ ~dev-cpp/folly-${PV}:=
+ dev-cpp/gflags
+ dev-cpp/glog
+ ~dev-cpp/wangle-${PV}:=
+ dev-libs/libfmt
+ dev-libs/openssl:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake_src_configure
+}