aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-04-15 14:50:18 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2021-04-15 14:50:37 +0200
commitebc43a593bd9673f38a0dbd71d05339b3eea2641 (patch)
tree6b4b37c3d82531f7f0ade7c6303c488070942284
parentgames-action/technic-launcher: install jar without version (diff)
downloadguru-ebc43a593bd9673f38a0dbd71d05339b3eea2641.tar.gz
guru-ebc43a593bd9673f38a0dbd71d05339b3eea2641.tar.bz2
guru-ebc43a593bd9673f38a0dbd71d05339b3eea2641.zip
games-util/NotEnoughProduction: install jar without version
Closes: https://bugs.gentoo.org/782952 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
-rw-r--r--games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild4
-rw-r--r--games-util/NotEnoughProduction/files/NotEnoughProduction2
2 files changed, 3 insertions, 3 deletions
diff --git a/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild b/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild
index 53abaced1..77d044161 100644
--- a/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild
+++ b/games-util/NotEnoughProduction/NotEnoughProduction-0.0.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -29,7 +29,7 @@ src_unpack() {
}
src_install() {
- java-pkg_newjar "${WORKDIR}/${P}.jar" "${P}.jar"
+ java-pkg_newjar "${WORKDIR}/${P}.jar" "${PN}.jar"
dobin "${FILESDIR}/${PN}"
diff --git a/games-util/NotEnoughProduction/files/NotEnoughProduction b/games-util/NotEnoughProduction/files/NotEnoughProduction
index 6dbd4488c..05289ad4a 100644
--- a/games-util/NotEnoughProduction/files/NotEnoughProduction
+++ b/games-util/NotEnoughProduction/files/NotEnoughProduction
@@ -3,7 +3,7 @@
# we need to execute this in a user writeable directory
mkdir -p ${HOME}/.local/share/NotEnoughProduction
-cp /usr/share/NotEnoughProduction/lib/NotEnoughProduction-*.jar ${HOME}/.local/share/NotEnoughProduction/NotEnoughProduction.jar
+cp /usr/share/NotEnoughProduction/lib/NotEnoughProduction.jar ${HOME}/.local/share/NotEnoughProduction/NotEnoughProduction.jar
pushd ${HOME}/.local/share/NotEnoughProduction
java -jar ${HOME}/.local/share/NotEnoughProduction/NotEnoughProduction.jar
popd