aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall T. Vasquez <ran.dall@icloud.com>2022-08-19 20:14:25 -0700
committerRandall T. Vasquez <ran.dall@icloud.com>2022-08-20 05:01:07 -0700
commitec527667a91d9e9b58aa45f471bc2d894614f956 (patch)
tree6286b07bf1d52855a8d0f0550699ab2f2914ba05
parentapp-editors/imhex: add myself as a maintainer (diff)
downloadguru-ec527667.tar.gz
guru-ec527667.tar.bz2
guru-ec527667.zip
gnome-extra/junction: new package, add 1.5.0, 9999
Signed-off-by: Randall T. Vasquez <ran.dall@icloud.com>
-rw-r--r--gnome-extra/junction/Manifest1
-rw-r--r--gnome-extra/junction/junction-1.5.0.ebuild38
-rw-r--r--gnome-extra/junction/junction-9999.ebuild38
-rw-r--r--gnome-extra/junction/metadata.xml14
4 files changed, 91 insertions, 0 deletions
diff --git a/gnome-extra/junction/Manifest b/gnome-extra/junction/Manifest
new file mode 100644
index 0000000000..0d414455cb
--- /dev/null
+++ b/gnome-extra/junction/Manifest
@@ -0,0 +1 @@
+DIST junction-1.5.0.tar.gz 1880000 BLAKE2B 390ea7db13d7642f66b8ff1179bc3822808aa73642f8391a16a5909428e01e51bfdcd8604f562c91c07cac95e6f365b09b452394a89bc6c8c50f7ab437df3273 SHA512 a3262aa5e37ba5cf57b90d060cbad742e3f52b84890ae336813f1a5e1150abe87d7ed7d1f9f16bf2488744504bdde2db5b392a39545c16bb37bcf712559c2f75
diff --git a/gnome-extra/junction/junction-1.5.0.ebuild b/gnome-extra/junction/junction-1.5.0.ebuild
new file mode 100644
index 0000000000..8048f64c4b
--- /dev/null
+++ b/gnome-extra/junction/junction-1.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Application/browser chooser"
+HOMEPAGE="https://apps.gnome.org/app/re.sonny.Junction/"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/sonnyp/Junction.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sonnyp/Junction/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${P/j/J}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ meson_src_configure \
+ --datadir=/usr/share
+}
+
+src_install() {
+ meson_src_compile
+}
+
+src_install() {
+ meson_src_install
+}
diff --git a/gnome-extra/junction/junction-9999.ebuild b/gnome-extra/junction/junction-9999.ebuild
new file mode 100644
index 0000000000..8048f64c4b
--- /dev/null
+++ b/gnome-extra/junction/junction-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Application/browser chooser"
+HOMEPAGE="https://apps.gnome.org/app/re.sonny.Junction/"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/sonnyp/Junction.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sonnyp/Junction/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${P/j/J}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ meson_src_configure \
+ --datadir=/usr/share
+}
+
+src_install() {
+ meson_src_compile
+}
+
+src_install() {
+ meson_src_install
+}
diff --git a/gnome-extra/junction/metadata.xml b/gnome-extra/junction/metadata.xml
new file mode 100644
index 0000000000..6fe292a30e
--- /dev/null
+++ b/gnome-extra/junction/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ran.dall@icloud.com</email>
+ <name>Randall Vasquez</name>
+ </maintainer>
+ <longdescription lang="en">
+ Application/browser chooser
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sonnyp/Junction</remote-id>
+ </upstream>
+</pkgmetadata>