aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-22 01:54:55 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-26 04:29:44 +0200
commitf086883f639d5e3a23cccde15d6b2df1a7e7397e (patch)
tree6edf92a895d51368b957ab187cec4cc1517f325e
parentapp-i18n/canna: new package, add 3.7_p3-r4 (diff)
downloadguru-f086883f.tar.gz
guru-f086883f.tar.bz2
guru-f086883f.zip
app-emacs/yc: new package, add 5.2.1
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--app-emacs/yc/Manifest1
-rw-r--r--app-emacs/yc/files/50yc-gentoo.el1
-rw-r--r--app-emacs/yc/files/sample.dot.emacs12
-rw-r--r--app-emacs/yc/files/sample.hosts.canna2
-rw-r--r--app-emacs/yc/files/yc-5.2.1-emacs-26.patch11
-rw-r--r--app-emacs/yc/metadata.xml9
-rw-r--r--app-emacs/yc/yc-5.2.1.ebuild42
7 files changed, 78 insertions, 0 deletions
diff --git a/app-emacs/yc/Manifest b/app-emacs/yc/Manifest
new file mode 100644
index 000000000..c25b225a8
--- /dev/null
+++ b/app-emacs/yc/Manifest
@@ -0,0 +1 @@
+DIST yc-5.2.1.el.gz 33305 BLAKE2B 8bed47715f49466425afefd036cf562055025564e50ae219e027848104e3851b6cba29f74bcf81487d2494d314a290eabe27e128968dbba9d475562e248a267b SHA512 11c8d63a9f6cb94118a00976518949ab50496f8b8f994a8e1c352be5deefc549540935e0727b036c2b3c493366cfb8c47f040fcc425174b6668ec9f5e8d499dc
diff --git a/app-emacs/yc/files/50yc-gentoo.el b/app-emacs/yc/files/50yc-gentoo.el
new file mode 100644
index 000000000..431f7e90a
--- /dev/null
+++ b/app-emacs/yc/files/50yc-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/yc/files/sample.dot.emacs b/app-emacs/yc/files/sample.dot.emacs
new file mode 100644
index 000000000..101532e70
--- /dev/null
+++ b/app-emacs/yc/files/sample.dot.emacs
@@ -0,0 +1,12 @@
+;;;; -*- mode: lisp-interaction; syntax: elisp; coding: iso-2022-7bit -*-
+
+;;;; Configuration for yc
+(setq yc-server-host "unix")
+;If you use inet socket service, enable the following line.
+;(setq yc-server-host "localhost")
+(setq yc-use-color t)
+(if (eq window-system 'x)
+ (setq yc-use-fence nil)
+ (setq yc-use-fence t))
+(load "yc")
+(global-yc-mode 1)
diff --git a/app-emacs/yc/files/sample.hosts.canna b/app-emacs/yc/files/sample.hosts.canna
new file mode 100644
index 000000000..960d75f52
--- /dev/null
+++ b/app-emacs/yc/files/sample.hosts.canna
@@ -0,0 +1,2 @@
+localhost
+unix
diff --git a/app-emacs/yc/files/yc-5.2.1-emacs-26.patch b/app-emacs/yc/files/yc-5.2.1-emacs-26.patch
new file mode 100644
index 000000000..19925c65c
--- /dev/null
+++ b/app-emacs/yc/files/yc-5.2.1-emacs-26.patch
@@ -0,0 +1,11 @@
+--- a/yc.el
++++ b/yc.el
+@@ -2071,7 +2071,7 @@
+ ;; $BJ8@a$r;XDj$7$J$$>l9g!"8=:_$NJ8@a$,BP>]$H$J$k(B
+ ;; $BFI$_$r<hF@$7$?J8@a$O$=$NFI$_$r%-%c%C%7%e$9$k(B
+ ;; cut $B$,(B $BHs(Bnil $B$N>l9g!";XDjJ8@a0J9_$NFI$_$r:o=|$9$k(B
+-(defun yc-yomi (&optional idx &optional cut)
++(defun yc-yomi (&optional idx cut)
+ (if (integerp idx)
+ (yc-put-bunsetsu-yomi idx (yc-get-bunsetsu-yomi idx cut) cut)
+ (yc-put-bunsetsu-yomi yc-mark (yc-get-bunsetsu-yomi yc-mark cut) cut)))
diff --git a/app-emacs/yc/metadata.xml b/app-emacs/yc/metadata.xml
new file mode 100644
index 000000000..37185a78f
--- /dev/null
+++ b/app-emacs/yc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <description>co-maintainers welcome</description>
+ <name>Alessandro Barbieri</name>
+ <email>lssndrbarbieri@gmail.com</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-emacs/yc/yc-5.2.1.ebuild b/app-emacs/yc/yc-5.2.1.ebuild
new file mode 100644
index 000000000..f76978fa9
--- /dev/null
+++ b/app-emacs/yc/yc-5.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Yet another Canna client on Emacsen"
+HOMEPAGE="http://www.ceres.dti.ne.jp/~knak/yc.html"
+SRC_URI="http://www.ceres.dti.ne.jp/~knak/${P}.el.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-i18n/canna"
+
+ELISP_PATCHES="${P}-emacs-26.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ dodoc "${FILESDIR}"/sample.{dot.emacs,hosts.canna}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ elog "See the sample.dot.emacs in ${EPREFIX}/usr/share/doc/${PF}."
+ elog
+ elog "And If you use unix domain socket for connecting the canna server,"
+ elog "please confirm that there's *no* following line in your ~/.emacs:"
+ elog ' (setq yc-server-host "localhost")'
+ elog
+ elog "If you use inet domain socket for connecting the canna server,"
+ elog "please modify as following in ${EPREFIX}/etc/conf.d/canna:"
+ elog ' CANNASERVER_OPTS="-inet"'
+ elog
+ elog "And create ${EPREFIX}/etc/hosts.canna."
+ elog "See the sample.hosts.canna in ${EPREFIX}/usr/share/doc/${PF}."
+}