aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2021-04-18 02:53:34 +0200
committerOliver Freyermuth <o.freyermuth@googlemail.com>2021-04-18 02:53:34 +0200
commitf518b2af305b931df4533dbea276f13279d74d60 (patch)
tree0cb822dae121a737ecef37f8ef0e20e96518c785
parentmedia-fonts/3270font: move to python-single-r1 (diff)
downloadguru-f518b2af.tar.gz
guru-f518b2af.tar.bz2
guru-f518b2af.zip
games-arcade/taisei: Migrate from xdg-utils to xdg eclass.
Allows to drop the pkg_* phases. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com>
-rw-r--r--games-arcade/taisei/taisei-1.3.1-r1.ebuild14
-rw-r--r--games-arcade/taisei/taisei-9999.ebuild14
2 files changed, 2 insertions, 26 deletions
diff --git a/games-arcade/taisei/taisei-1.3.1-r1.ebuild b/games-arcade/taisei/taisei-1.3.1-r1.ebuild
index 381361ff3..8ec848b13 100644
--- a/games-arcade/taisei/taisei-1.3.1-r1.ebuild
+++ b/games-arcade/taisei/taisei-1.3.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit meson python-any-r1 xdg-utils
+inherit meson python-any-r1 xdg
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -54,15 +54,3 @@ src_configure() {
)
meson_src_configure
}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
diff --git a/games-arcade/taisei/taisei-9999.ebuild b/games-arcade/taisei/taisei-9999.ebuild
index a50bcba07..a1029653d 100644
--- a/games-arcade/taisei/taisei-9999.ebuild
+++ b/games-arcade/taisei/taisei-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit meson python-any-r1 xdg-utils
+inherit meson python-any-r1 xdg
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -55,15 +55,3 @@ src_configure() {
)
meson_src_configure
}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}