aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2022-09-06 23:25:46 +0000
committerAisha Tammy <gentoo@aisha.cc>2022-09-06 23:25:46 +0000
commitf5e0a0d48ffe02175884e72c2aa94e3cbe7fa84c (patch)
tree578f6a1e5283e8aac6edbcbfb76d0a0bb96d7102
parentnet-libs/dpdk: remove -machine option (diff)
downloadguru-f5e0a0d4.tar.gz
guru-f5e0a0d4.tar.bz2
guru-f5e0a0d4.zip
dev-cpp/workflow: add 0.10.3
Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
-rw-r--r--dev-cpp/workflow/Manifest1
-rw-r--r--dev-cpp/workflow/workflow-0.10.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-cpp/workflow/Manifest b/dev-cpp/workflow/Manifest
index b853273fc..6f8c2e3b8 100644
--- a/dev-cpp/workflow/Manifest
+++ b/dev-cpp/workflow/Manifest
@@ -1 +1,2 @@
DIST workflow-0.10.2.tar.gz 389218 BLAKE2B d02d9df7cb9fbcaa9280cc4ec5dfa16a2226fab15515ffa4beb45572e44024f405c5d3fa02aba994aecb8659c9e623bcf45c5cd6a44d9b38f9234ab65fc8764c SHA512 19e35a7179f4323e401bed21a203e465b35cb45dee9b78e4ecaa1ece2569758e06e2d2550fdba99ca268943254f2aeed6c3d86d32a02a32975b6dc04fc55c57a
+DIST workflow-0.10.3.tar.gz 394650 BLAKE2B ba246ceb620bc2122e316b5288cf4b8f58203f1c1d61b63e0e2b0a02f1a8b1c7a18b74409bb35bc1a4bacd07635e0ba91a677659ea712f5afc70c5d79f91a49c SHA512 5511f5d0c8b8c040e7316c7629b47648c4a6a1871b63ead33329cfa57d3c1b19e7aad1056487f92e5579d5baa354db3e4c002beb3c7f9b3d922cce4d9881ce36
diff --git a/dev-cpp/workflow/workflow-0.10.3.ebuild b/dev-cpp/workflow/workflow-0.10.3.ebuild
new file mode 100644
index 000000000..35d33b083
--- /dev/null
+++ b/dev-cpp/workflow/workflow-0.10.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ Parallel Computing and Asynchronous Networking Engine"
+HOMEPAGE="https://github.com/sogou/workflow"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sogou/workflow"
+else
+ SRC_URI="https://github.com/sogou/workflow/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/openssl:0=
+"
+DEPEND="${RDEPEND}
+ dev-cpp/gtest
+"
+
+PATCHES=(
+ "${FILESDIR}/workflow-0.10.2-enable-tests.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+ mkdir docs/cn || die
+ mv docs/*.md docs/cn || die
+}
+
+src_install() {
+ cmake_src_install
+ dodoc -r docs/.
+}