aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-06-28 06:43:14 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-07-01 09:58:26 +0500
commitf7d989bc03ba9abf53c390d282f15e6ab4d16280 (patch)
tree4516251df89b505f7a48dc31b92af9f60470ec59
parentdev-cpp/pcg-cpp: add .pc file + examples use flag (diff)
downloadguru-f7d989bc.tar.gz
guru-f7d989bc.tar.bz2
guru-f7d989bc.zip
games-server/among-sus: initial import
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--games-server/among-sus/Manifest1
-rw-r--r--games-server/among-sus/among-sus-20210519.ebuild35
-rw-r--r--games-server/among-sus/files/among-sus.confd1
-rw-r--r--games-server/among-sus/files/among-sus.initd18
-rw-r--r--games-server/among-sus/metadata.xml14
5 files changed, 69 insertions, 0 deletions
diff --git a/games-server/among-sus/Manifest b/games-server/among-sus/Manifest
new file mode 100644
index 000000000..512824baa
--- /dev/null
+++ b/games-server/among-sus/Manifest
@@ -0,0 +1 @@
+DIST among-sus-20210519.tar.gz 23784 BLAKE2B d9a215c0654f1db3d39e8ed10f792a464a1e843e863cbb5c986b6074885d10a9912ba143f8e1f692e001e7b495296b0cf92f1ce62cd533a0f7aabe871900cb5f SHA512 873a736a02f921758f3c5faac0b5d46c5f5f36f605fbfb0c5da42544a4fbd27bc73d1a2f1f82468c3f173cf4c25a28eee35d9f6b83c0809c59fb0aa954d925ab
diff --git a/games-server/among-sus/among-sus-20210519.ebuild b/games-server/among-sus/among-sus-20210519.ebuild
new file mode 100644
index 000000000..c0d8b11e4
--- /dev/null
+++ b/games-server/among-sus/among-sus-20210519.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+COMMIT="554e60bf52e3fa931661b9414189a92bb8f69d78"
+DESCRIPTION="Among Us, but it's a text adventure"
+HOMEPAGE="https://sr.ht/~martijnbraam/among-sus"
+SRC_URI="https://tildegit.org/tildeverse/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+notifications"
+
+src_configure() {
+ append-cppflags \
+ -DVERSION=\\\"${COMMIT:0:7}\\\" \
+ -DMOVEMENT_NOTIFICATIONS=$(usex notifications 1 0)
+}
+
+src_compile() {
+ emake main
+}
+
+src_install() {
+ newbin main ${PN}
+ einstalldocs
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
diff --git a/games-server/among-sus/files/among-sus.confd b/games-server/among-sus/files/among-sus.confd
new file mode 100644
index 000000000..86c4ccab6
--- /dev/null
+++ b/games-server/among-sus/files/among-sus.confd
@@ -0,0 +1 @@
+# AMOGUS_PORT=1234
diff --git a/games-server/among-sus/files/among-sus.initd b/games-server/among-sus/files/among-sus.initd
new file mode 100644
index 000000000..14886c2b5
--- /dev/null
+++ b/games-server/among-sus/files/among-sus.initd
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="among-sus server"
+description="Among Us, but it's a text adventure"
+
+AMOGUS_PORT=${AMOGUS_PORT:-1234}
+
+command="/usr/bin/among-sus"
+command_args="-p ${AMOGUS_PORT}"
+command_user=nobody:nobody
+command_background=1
+pidfile=/run/among-sus.pid
+
+depend() {
+ need net
+}
diff --git a/games-server/among-sus/metadata.xml b/games-server/among-sus/metadata.xml
new file mode 100644
index 000000000..a90138a52
--- /dev/null
+++ b/games-server/among-sus/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://todo.sr.ht/~martijnbraam/among-sus</bugs-to>
+ </upstream>
+ <use>
+ <flag name="notifications">Notify players you're moving</flag>
+ </use>
+</pkgmetadata>