aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-03 11:15:25 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-03 12:37:11 +0500
commitf864c5051ca065045e68317465e4c7b1d0563db6 (patch)
tree60d919032fdf1701b7ca5c89515a7043d84c8a84
parentdev-python/pytest-benchmark: add 4.0.0 (diff)
downloadguru-f864c505.tar.gz
guru-f864c505.tar.bz2
guru-f864c505.zip
dev-python/aspectlib: add 2.0.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--dev-python/aspectlib/Manifest1
-rw-r--r--dev-python/aspectlib/aspectlib-2.0.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/aspectlib/Manifest b/dev-python/aspectlib/Manifest
index b2f724d61..664b7cc5f 100644
--- a/dev-python/aspectlib/Manifest
+++ b/dev-python/aspectlib/Manifest
@@ -1 +1,2 @@
DIST aspectlib-1.5.2.gh.tar.gz 155976 BLAKE2B a5f98c78e098226002a9cfb95cd69d2da057fe5a56cab5ae13c80666e1220c8a0fb9ae1b3f652e85d54ab9829429f9aad37162eac9cc74a4ffaab9ab1f609c1c SHA512 33642f828989d07c6af78bdf9adc9f2abbc419df89b878cfe7bd9c8df226a59401176b56b1f2b3ba48661ea5a145520de0bc7a0980226b742b0a79f31ab7dd7f
+DIST aspectlib-2.0.0.gh.tar.gz 149206 BLAKE2B 79a9cdd6090181e28bb9f46b5dc71b5a49c6fe356f0d4687886df2b6d83867a8a8bd51e43506da09b78e3ae637a1f1257888656fd2ecb0f583986424f89d3d14 SHA512 455ae7bb7808158abc79814632cd108397bfffc4d6c5e0f8a041ca03ed0f0fc2022d0929ad3a29e9015d8b3e3b02afa071c9b28fc62845eac4f6ef8c3fa2d9b2
diff --git a/dev-python/aspectlib/aspectlib-2.0.0.ebuild b/dev-python/aspectlib/aspectlib-2.0.0.ebuild
new file mode 100644
index 000000000..ae96ac2a0
--- /dev/null
+++ b/dev-python/aspectlib/aspectlib-2.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An aspect-oriented programming, monkey-patch and decorators library"
+HOMEPAGE="
+ https://github.com/ionelmc/python-aspectlib
+ https://pypi.org/project/python-aspectlib/
+"
+SRC_URI="https://github.com/ionelmc/python-${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/fields[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/process-tests[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+)"
+
+S="${WORKDIR}/python-${P}"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme
+
+EEPYTEST_DESELECT=(
+ # fails because error message text is slightly different
+ tests/test_aspectlib_test.py::test_story_empty_play_proxy_class
+ tests/test_aspectlib_test.py::test_story_half_play_proxy_class
+)