aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Syutkin <syutkin@gmail.com>2021-06-17 19:51:48 +0300
committerAndrey Syutkin <syutkin@gmail.com>2021-06-17 19:55:08 +0300
commitf974ebac64e3711521daeb72f68708950754507a (patch)
tree7aa762c409d9f6725935328f8c33635f22405c1b
parentdev-R/ggplot2: add 3.3.4, drop 3.3.3 (diff)
downloadguru-f974ebac.tar.gz
guru-f974ebac.tar.bz2
guru-f974ebac.zip
app-misc/far2l: add required python deps, drop 2.3.20210419
Signed-off-by: Andrey Syutkin <syutkin@gmail.com>
-rw-r--r--app-misc/far2l/Manifest1
-rw-r--r--app-misc/far2l/far2l-2.3.20210419_alpha.ebuild86
-rw-r--r--app-misc/far2l/far2l-2.3.20210426_alpha.ebuild4
-rw-r--r--app-misc/far2l/far2l-9999.ebuild5
4 files changed, 6 insertions, 90 deletions
diff --git a/app-misc/far2l/Manifest b/app-misc/far2l/Manifest
index 1cc40960ad..e073873f00 100644
--- a/app-misc/far2l/Manifest
+++ b/app-misc/far2l/Manifest
@@ -1,2 +1 @@
-DIST far2l-2.3.20210419_alpha.tar.gz 5441978 BLAKE2B d8878704d5928d5240e1cdcf32dc3e2bd298c3a283811ae29a9cff36c20d1ae8b655ea5355f7c41660eb91b6e53b6c26cf66e93f7d4fc59e12ad3ee1e2cac4b0 SHA512 99b98f5946ce93ddbd93a9d26ce4db22ee687e7c9cbaab53b0087896a9a8247041064614b489d5e6e0a0d4ead72057db5bcbdbf6b060e36b9eb4f61aa30dec38
DIST far2l-2.3.20210426_alpha.tar.gz 5441382 BLAKE2B d6f1c2611d4c149755bf7bf7b25428030489f56b3ff5a0f8a5d4703b2229c45a4d35ec6ce3b7b90681690135028678b29cd3062be5fe74eb5a4494edfe3a2b93 SHA512 28a4e819c36815d8e754ea04b57631ee61d5c48ecfe32ce7d7a45564d8f3e08dd8cdcc5a34d3c8c4abc45b143d819c286ad95cbdc281c6b94e8599ff3acdcec3
diff --git a/app-misc/far2l/far2l-2.3.20210419_alpha.ebuild b/app-misc/far2l/far2l-2.3.20210419_alpha.ebuild
deleted file mode 100644
index 85318fa2b2..0000000000
--- a/app-misc/far2l/far2l-2.3.20210419_alpha.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-WX_GTK_VER="3.0-gtk3"
-
-inherit cmake xdg wxwidgets python-r1
-
-DESCRIPTION="Linux port of FAR Manager v2"
-HOMEPAGE="https://github.com/elfmz/far2l"
-
-if [[ "${PV}" == "9999" ]] ; then
- inherit git-r3
- SRC_URI=""
- EGIT_REPO_URI="https://github.com/elfmz/far2l"
- EGIT_BRANCH="master"
-else
- MY_PV="${PV:4:4}-${PV:8:2}-${PV:10:8}"
- MY_P="${PN}-${MY_PV}"
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://github.com/elfmz/far2l/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+ssl sftp samba nfs webdav +archive +wxwidgets python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-BDEPEND="sys-devel/m4"
-
-RDEPEND="dev-libs/xerces-c
- dev-libs/spdlog
- app-i18n/uchardet
- wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER} )
- ssl? ( dev-libs/openssl )
- sftp? ( net-libs/libssh[sftp] )
- samba? ( net-fs/samba )
- nfs? ( net-fs/libnfs )
- webdav? ( net-libs/neon )
- archive? (
- dev-libs/libpcre2
- app-arch/libarchive )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/virtualenv[${PYTHON_USEDEP}]')
- )"
-
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md )
-
-pkg_setup() {
- if use wxwidgets; then
- setup-wxwidgets
- fi
-}
-
-src_prepare() {
- sed -e "s:execute_process(COMMAND ln -sf \../../bin/far2l \${CMAKE_INSTALL_PREFIX}/lib/far2l/far2l_askpass)::" -i "${S}"/CMakeLists.txt || die
- sed -e "s:execute_process(COMMAND ln -sf \../../bin/far2l \${CMAKE_INSTALL_PREFIX}/lib/far2l/far2l_sudoapp)::" -i "${S}"/CMakeLists.txt || die
- sed -e "s:execute_process(COMMAND rm -f \${CMAKE_INSTALL_PREFIX}/lib/far2l/Plugins/objinfo/plug/objinfo.far-plug-mb)::" -i "${S}"/CMakeLists.txt || die
- sed -e "s:execute_process(COMMAND rm -f \${CMAKE_INSTALL_PREFIX}/lib/far2l/Plugins/farftp/plug/farftp.far-plug-mb && echo Removed existing farftp plugin)::" -i "${S}"/CMakeLists.txt || die
- sed -e "s:execute_process(COMMAND rm -f \${CMAKE_INSTALL_PREFIX}/lib/far2l/Plugins/python/plug/python.far-plug-wide && echo Removed existing python plugin)::" -i "${S}"/CMakeLists.txt || die
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSEWX="$(usex wxwidgets)"
- -DPYTHON="$(usex python)"
- -DBUILD_SHARED_LIBS=OFF
- )
-
- cmake_src_configure
-}
-
-src_install(){
- cmake_src_install
- einstalldocs
- dosym "../../bin/far2l" "usr/lib/far2l/far2l_askpass"
- dosym "../../bin/far2l" "usr/lib/far2l/far2l_sudoapp"
-}
diff --git a/app-misc/far2l/far2l-2.3.20210426_alpha.ebuild b/app-misc/far2l/far2l-2.3.20210426_alpha.ebuild
index 85318fa2b2..ea9fb33775 100644
--- a/app-misc/far2l/far2l-2.3.20210426_alpha.ebuild
+++ b/app-misc/far2l/far2l-2.3.20210426_alpha.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
WX_GTK_VER="3.0-gtk3"
@@ -46,6 +46,8 @@ RDEPEND="dev-libs/xerces-c
app-arch/libarchive )
python? (
${PYTHON_DEPS}
+ virtual/python-cffi
+ dev-python/debugpy
$(python_gen_any_dep 'dev-python/virtualenv[${PYTHON_USEDEP}]')
)"
diff --git a/app-misc/far2l/far2l-9999.ebuild b/app-misc/far2l/far2l-9999.ebuild
index 85318fa2b2..dd01ac84a2 100644
--- a/app-misc/far2l/far2l-9999.ebuild
+++ b/app-misc/far2l/far2l-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
WX_GTK_VER="3.0-gtk3"
@@ -46,7 +46,8 @@ RDEPEND="dev-libs/xerces-c
app-arch/libarchive )
python? (
${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/virtualenv[${PYTHON_USEDEP}]')
+ virtual/python-cffi
+ dev-python/debugpy
)"
DEPEND="${RDEPEND}"