aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-09-02 03:24:15 +0200
committerMaciej Barć <xgqt@riseup.net>2021-09-02 03:24:24 +0200
commitfbc9b0cbaee5291620a6cdb7add3d61751ce9594 (patch)
tree19443f68d435f62fd6bb41b1e94389bfba8fdf94
parentmedia-sound/mopidy: new package (diff)
downloadguru-fbc9b0cb.tar.gz
guru-fbc9b0cb.tar.bz2
guru-fbc9b0cb.zip
games-emulation/melonds: bump to 0.9.3
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@riseup.net>
-rw-r--r--games-emulation/melonds/Manifest1
-rw-r--r--games-emulation/melonds/melonds-0.9.3.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index 439e3d062..f284f28e8 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1 +1,2 @@
DIST melonDS-0.9.2.tar.gz 1330793 BLAKE2B e504dd2e1344a9680b9820f7f0308fa30decb16f40675df5649babef7ab3fae9528042fc2737a36bafdd28b9125f94a79d20e5a5e791d485feb9dc26b64b1432 SHA512 3d099af675acdcb91431aaaf95bc27c10fd432ebd29aa81c7eb4e65dfad9c20cb4fd5de086d2162cbe4a6b41f7e140880a5742b1ec34eef0511fff052aa1baaa
+DIST melonDS-0.9.3.tar.gz 2241325 BLAKE2B 0ea7fbcce039a60a0553ae45d11f0b1550bfec2300faf1c99c3ee531bd5949c7293bec187fbf53e400bbb6280df29db141b2d1bcb294a8abf2eabb71993db686 SHA512 37f26f3a9784873ce1664645cea70049725367f5fe62f7c58842ebd5da2c73ffe423695dddb0ffd444bdf59df2a3fcd778cdf95b2bb083014b961fed282953f5
diff --git a/games-emulation/melonds/melonds-0.9.3.ebuild b/games-emulation/melonds/melonds-0.9.3.ebuild
new file mode 100644
index 000000000..21069e621
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.9.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE:
+# melonds bundles teakra, its upstream haven't had a release since 2020
+
+EAPI=7
+
+MY_PN="melonDS"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="
+ http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS
+"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arisotura/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+IUSE="+jit +opengl"
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+
+DEPEND="
+ app-arch/libarchive
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ media-libs/libsdl2[sound,video]
+ net-libs/libslirp
+ net-libs/libpcap
+ opengl? ( media-libs/libepoxy )
+"
+RDEPEND="${DEPEND}"
+
+# used for JIT recompiler
+QA_EXECSTACK="usr/bin/melonDS"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_JIT=$(usex jit)
+ -DENABLE_OGLRENDERER=$(usex opengl)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ # install teakra
+ dolib.so "${BUILD_DIR}/src/teakra/src/libteakra.so"
+
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog "You need the following files in order to run melonDS:"
+ elog "- bios7.bin"
+ elog "- bios9.bin"
+ elog "- firmware.bin"
+ elog "- romlist.bin"
+ elog "Place them in ~/.config/melonDS"
+ elog "Those files can be found somewhere on the Internet ;-)"
+}