aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-28 00:17:43 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-06-28 00:17:43 +0200
commitfe3c738c21b0f614174fdc508340c83a3df2052e (patch)
tree1842bc08f6f7861ea18a018618af0c68d754b077
parent*/*: take packages (WIP) (diff)
downloadguru-fe3c738c.tar.gz
guru-fe3c738c.tar.bz2
guru-fe3c738c.zip
sys-cluster/pcs: fix patches, remove old
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sys-cluster/pcs/Manifest1
-rw-r--r--sys-cluster/pcs/files/openrc-0.10.7.patch430
-rw-r--r--sys-cluster/pcs/files/openrc-0.10.8.patch32
-rw-r--r--sys-cluster/pcs/files/pcsd-daemon.service.patch4
-rw-r--r--sys-cluster/pcs/pcs-0.10.7.ebuild112
-rw-r--r--sys-cluster/pcs/pcs-0.10.8-r3.ebuild (renamed from sys-cluster/pcs/pcs-0.10.8-r2.ebuild)7
-rw-r--r--sys-cluster/pcs/pcs-0.10.8.ebuild112
7 files changed, 22 insertions, 676 deletions
diff --git a/sys-cluster/pcs/Manifest b/sys-cluster/pcs/Manifest
index 79ce84cab..95eae5e99 100644
--- a/sys-cluster/pcs/Manifest
+++ b/sys-cluster/pcs/Manifest
@@ -1,2 +1 @@
-DIST pcs-0.10.7.tar.gz 1818215 BLAKE2B 345ba114f92c1f555a948b1f6eafb532056d3196c9f0cf3007d7d27d8a8957c886f3a5ab2519e0922908c3d11ed9dc54632376d5556f6b1dc5dfb035bcfda4bf SHA512 c76a11fa162258ee311dcceca50674d7638396880596a826a711d944aab421ed06a6c4eb41f9dc997c01b72bce73c98c4f7be3fcd8fafb8ae16902f6a1e0c521
DIST pcs-0.10.8.tar.gz 1852902 BLAKE2B ef023ca27c2dbd1d765e1d68f67a55c79f57b1dbc7d571b8f21e1c30f8a8510b1148459a0e683c682fb969c7635ef726c8e227b995d1a35dfd27894f40bdaa26 SHA512 8b9ba62279431e481d062e804d24480d2a274d2f4897a82149df6116ff3df2394d97a3ee77a6dee4c563d915bab0142124a8942524fcc4e894912086e865353c
diff --git a/sys-cluster/pcs/files/openrc-0.10.7.patch b/sys-cluster/pcs/files/openrc-0.10.7.patch
deleted file mode 100644
index 18c56936a..000000000
--- a/sys-cluster/pcs/files/openrc-0.10.7.patch
+++ /dev/null
@@ -1,430 +0,0 @@
---- a/pcs-0.10.7/pcs/lib/external.py
-+++ b/pcs-0.10.7/pcs/lib/external.py
-@@ -13,8 +13,8 @@
- from pcs.lib.errors import LibraryError
-
-
--_chkconfig = settings.chkconfig_binary
--_service = settings.service_binary
-+_rc_config = settings.rc_config_binary
-+_rc_service = settings.rc_service_binary
- _systemctl = settings.systemctl_binary
-
-
-@@ -192,7 +192,7 @@
- [_systemctl, "disable", _get_service_name(service, instance)]
- )
- else:
-- stdout, stderr, retval = runner.run([_chkconfig, service, "off"])
-+ stdout, stderr, retval = runner.run([_rc_config, 'delete', service, "default"])
- if retval != 0:
- raise DisableServiceError(
- service, join_multilines([stderr, stdout]), instance
-@@ -214,7 +214,7 @@
- [_systemctl, "enable", _get_service_name(service, instance)]
- )
- else:
-- stdout, stderr, retval = runner.run([_chkconfig, service, "on"])
-+ stdout, stderr, retval = runner.run([_rc_config, 'add', service, "default"])
- if retval != 0:
- raise EnableServiceError(
- service, join_multilines([stderr, stdout]), instance
-@@ -234,7 +234,7 @@
- [_systemctl, "start", _get_service_name(service, instance)]
- )
- else:
-- stdout, stderr, retval = runner.run([_service, service, "start"])
-+ stdout, stderr, retval = runner.run([_rc_service, service, "start"])
- if retval != 0:
- raise StartServiceError(
- service, join_multilines([stderr, stdout]), instance
-@@ -254,7 +254,7 @@
- [_systemctl, "stop", _get_service_name(service, instance)]
- )
- else:
-- stdout, stderr, retval = runner.run([_service, service, "stop"])
-+ stdout, stderr, retval = runner.run([_rc_service, service, "stop"])
- if retval != 0:
- raise StopServiceError(
- service, join_multilines([stderr, stdout]), instance
-@@ -295,8 +295,12 @@
- [_systemctl, "is-enabled", _get_service_name(service, instance)]
- )
- else:
-- dummy_stdout, dummy_stderr, retval = runner.run([_chkconfig, service])
--
-+ stdout, dummy_stderr, dummy_retval = runner.run([_rc_config, 'list', 'default'])
-+ retval = 1
-+ for line in stdout.splitlines():
-+ line = line.split(' ')[0]
-+ if service == line:
-+ retval = 0
- return retval == 0
-
-
-@@ -316,7 +320,7 @@
- )
- else:
- dummy_stdout, dummy_stderr, retval = runner.run(
-- [_service, service, "status"]
-+ [_rc_service, service, "status"]
- )
-
- return retval == 0
-@@ -344,8 +348,7 @@
- """
- if is_systemctl():
- return []
--
-- stdout, dummy_stderr, return_code = runner.run([_chkconfig])
-+ stdout, dummy_stderr, return_code = runner.run([_rc_config, "list"])
- if return_code != 0:
- return []
-
---- a/pcs-0.10.7/pcs/settings_default.py
-+++ b/pcs-0.10.7/pcs/settings_default.py
-@@ -1,8 +1,8 @@
- import os.path
-
- systemctl_binary = "/bin/systemctl"
--chkconfig_binary = "/sbin/chkconfig"
--service_binary = "/sbin/service"
-+rc_config_binary = "/usr/bin/rc-config"
-+rc_service_binary = "/sbin/rc-service"
- pacemaker_binaries = "/usr/sbin/"
- crm_resource_binary = os.path.join(pacemaker_binaries, "crm_resource")
- corosync_binaries = "/usr/sbin/"
-@@ -41,7 +41,7 @@
- crm_mon_schema = "/usr/share/pacemaker/crm_mon.rng"
- agent_metadata_schema = "/usr/share/resource-agents/ra-api-1.dtd"
- pcsd_var_location = "/var/lib/pcsd/"
--pcsd_ruby_socket = "/run/pcsd-ruby.socket"
-+pcsd_ruby_socket = "/run/pcsd-daemon.socket"
- pcsd_cert_location = os.path.join(pcsd_var_location, "pcsd.crt")
- pcsd_key_location = os.path.join(pcsd_var_location, "pcsd.key")
- pcsd_known_hosts_location = os.path.join(pcsd_var_location, "known-hosts")
-@@ -59,7 +59,7 @@
- pacemaker_gname = "haclient"
- sbd_binary = "/usr/sbin/sbd"
- sbd_watchdog_default = "/dev/watchdog"
--sbd_config = "/etc/sysconfig/sbd"
-+sbd_config = "/etc/default/sbd"
- # this limit is also mentioned in docs, change there as well
- sbd_max_device_num = 3
- # message types are also mentioned in docs, change there as well
---- a/pcs-0.10.7/pcs/settings.py.debian
-+++ b/pcs-0.10.7/pcs/settings.py.debian
-@@ -1,10 +1,10 @@
- from pcs.settings_default import *
--service_binary = "/usr/sbin/service"
-+rc-service_binary = "/sbin/rc-service"
- corosync_log_file = "/var/log/corosync/corosync.log"
--pacemaker_schedulerd = "/usr/lib/pacemaker/pacemaker-schedulerd"
--pacemaker_controld = "/usr/lib/pacemaker/pacemaker-controld"
--pacemaker_based = "/usr/lib/pacemaker/pacemaker-based"
--pacemaker_fenced = "/usr/lib/pacemaker/pacemaker-fenced"
-+pacemaker_schedulerd = "/usr/libexec/pacemaker/pacemaker-schedulerd"
-+pacemaker_controld = "/usr/libexec/pacemaker/pacemaker-controld"
-+pacemaker_based = "/usr/libexec/pacemaker/pacemaker-based"
-+pacemaker_fenced = "/usr/libexec/pacemaker/pacemaker-fenced"
- pcsd_exec_location = "/usr/share/pcsd/"
- pcsd_gem_path = None
- pcsd_config = "/etc/default/pcsd"
---- a/pcs-0.10.7/pcs/utils.py
-+++ b/pcs-0.10.7/pcs/utils.py
-@@ -2187,7 +2187,7 @@
- )
- else:
- stdout, stderr, retval = cmd_runner().run(
-- [settings.service_binary, service, "start"]
-+ [settings.rc_service_binary, service, "start"]
- )
- return join_multilines([stderr, stdout]), retval
-
-@@ -2202,7 +2202,7 @@
- )
- else:
- stdout, stderr, retval = cmd_runner().run(
-- [settings.service_binary, service, "stop"]
-+ [settings.rc_service_binary, service, "stop"]
- )
- return join_multilines([stderr, stdout]), retval
-
---- a/pcs-0.10.7/pcsd/pcs.rb
-+++ b/pcs-0.10.7/pcsd/pcs.rb
-@@ -1708,11 +1708,22 @@
- def is_service_enabled?(service)
- if ISSYSTEMCTL
- cmd = ['systemctl', 'is-enabled', "#{service}.service"]
-+ _, _, retcode = run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
-+ return (retcode == 0)
- else
-- cmd = ['chkconfig', service]
-+ cmd = ['rc-config', 'list', 'default']
-+ stdout, _, retcode = run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
-+ if retcode != 0
-+ return false
-+ end
-+ stdout.each { |line|
-+ line = line.split(' ')
-+ if line[0] == service
-+ return true
-+ end
-+ }
-+ return false
- end
-- _, _, retcode = run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
-- return (retcode == 0)
- end
-
- def is_service_running?(service)
-@@ -1722,7 +1733,7 @@
- # encoding/decoding errors. We are not interested in the lines anyway.
- cmd = ['systemctl', 'status', '--lines=0', "#{service}.service"]
- else
-- cmd = ['service', service, 'status']
-+ cmd = ['rc-service', service, 'status']
- end
- _, _, retcode = run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
- return (retcode == 0)
-@@ -1775,7 +1786,8 @@
- class ServiceInstalledCheckerChkconfig < ServiceInstalledChecker
- protected
- def run_command
-- return run_cmd(PCSAuth.getSuperuserAuth(), 'chkconfig')
-+ cmd = ['rc-config', 'list']
-+ return run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
- end
-
- def contains_line_service?(line, service)
-@@ -1802,7 +1814,7 @@
- cmd = ['systemctl', 'enable', "#{service}.service"]
- else
- # fails when the service is not installed
-- cmd = ['chkconfig', service, 'on']
-+ cmd = ['rc-config', 'add', service, 'default']
- end
- _, _, retcode = run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
- return (retcode == 0)
-@@ -1817,7 +1829,7 @@
- if ISSYSTEMCTL
- cmd = ['systemctl', 'disable', "#{service}.service"]
- else
-- cmd = ['chkconfig', service, 'off']
-+ cmd = ['rc-config', 'delete', service, 'default']
- end
- _, _, retcode = run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
- return (retcode == 0)
-@@ -1827,7 +1839,7 @@
- if ISSYSTEMCTL
- cmd = ['systemctl', 'start', "#{service}.service"]
- else
-- cmd = ['service', service, 'start']
-+ cmd = ['rc-service', service, 'start']
- end
- _, _, retcode = run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
- return (retcode == 0)
-@@ -1840,7 +1852,7 @@
- if ISSYSTEMCTL
- cmd = ['systemctl', 'stop', "#{service}.service"]
- else
-- cmd = ['service', service, 'stop']
-+ cmd = ['rc-service', service, 'stop']
- end
- _, _, retcode = run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
- return (retcode == 0)
-I file binari a/pcs-0.10.7/pcsd/.pcs.rb.swp e b/pcs-0.10.7/pcsd/.pcs.rb.swp sono diversi
---- a/pcs-0.10.7/pcsd/settings.rb
-+++ b/pcs-0.10.7/pcsd/settings.rb
-@@ -3,7 +3,7 @@
- PCSD_EXEC_LOCATION = '/usr/lib/pcsd/'
- PCSD_VAR_LOCATION = '/var/lib/pcsd/'
- PCSD_DEFAULT_PORT = 2224
--PCSD_RUBY_SOCKET = '/run/pcsd-ruby.socket'
-+PCSD_RUBY_SOCKET = '/run/pcsd-daemon.socket'
-
- CRT_FILE = PCSD_VAR_LOCATION + 'pcsd.crt'
- KEY_FILE = PCSD_VAR_LOCATION + 'pcsd.key'
---- a/pcs-0.10.7/pcsd/settings.rb.debian
-+++ b/pcs-0.10.7/pcsd/settings.rb.debian
-@@ -3,7 +3,7 @@
- PCSD_EXEC_LOCATION = '/usr/share/pcsd/'
- PCSD_VAR_LOCATION = '/var/lib/pcsd/'
- PCSD_DEFAULT_PORT = 2224
--PCSD_RUBY_SOCKET = '/run/pcsd-ruby.socket'
-+PCSD_RUBY_SOCKET = '/run/pcsd-daemon.socket'
-
- CRT_FILE = PCSD_VAR_LOCATION + 'pcsd.crt'
- KEY_FILE = PCSD_VAR_LOCATION + 'pcsd.key'
---- a/pcs-0.10.7/pcs_test/tier0/lib/test_external.py
-+++ b/pcs-0.10.7/pcs_test/tier0/lib/test_external.py
-@@ -16,8 +16,8 @@
- import pcs.lib.external as lib
-
-
--_chkconfig = settings.chkconfig_binary
--_service = settings.service_binary
-+_rc_config = settings.rc_config_binary
-+_rc_service = settings.rc_service_binary
- _systemctl = settings.systemctl_binary
-
-
-@@ -415,7 +415,7 @@
- self.mock_runner, self.service, None
- )
- self.mock_runner.run.assert_called_once_with(
-- [_chkconfig, self.service, "off"]
-+ [_rc_config, "delete", self.service, "default"]
- )
-
- def test_not_systemctl_failed(self, mock_is_installed, mock_systemctl):
-@@ -430,7 +430,7 @@
- self.mock_runner, self.service, None
- )
- self.mock_runner.run.assert_called_once_with(
-- [_chkconfig, self.service, "off"]
-+ [_rc_config, "delete", self.service, "default"]
- )
-
- def test_systemctl_not_installed(self, mock_is_installed, mock_systemctl):
-@@ -480,7 +480,7 @@
- self.mock_runner, self.service, instance
- )
- self.mock_runner.run.assert_called_once_with(
-- [_chkconfig, self.service, "off"]
-+ [_rc_config, "delete", self.service, "default"]
- )
-
-
-@@ -514,7 +514,7 @@
- self.mock_runner.run.return_value = ("", "", 0)
- lib.enable_service(self.mock_runner, self.service)
- self.mock_runner.run.assert_called_once_with(
-- [_chkconfig, self.service, "on"]
-+ [_rc_config, "add", self.service, "default"]
- )
-
- def test_not_systemctl_failed(self, mock_systemctl):
-@@ -525,7 +525,7 @@
- lambda: lib.enable_service(self.mock_runner, self.service),
- )
- self.mock_runner.run.assert_called_once_with(
-- [_chkconfig, self.service, "on"]
-+ [_rc_config, "add", self.service, "default"]
- )
-
- def test_instance_systemctl(self, mock_systemctl):
-@@ -545,7 +545,7 @@
- self.mock_runner.run.return_value = ("", "", 0)
- lib.enable_service(self.mock_runner, self.service, instance="test")
- self.mock_runner.run.assert_called_once_with(
-- [_chkconfig, self.service, "on"]
-+ [_rc_config, "add", self.service, "default"]
- )
-
-
-@@ -579,7 +579,7 @@
- self.mock_runner.run.return_value = ("Starting...", "", 0)
- lib.start_service(self.mock_runner, self.service)
- self.mock_runner.run.assert_called_once_with(
-- [_service, self.service, "start"]
-+ [_rc_service, self.service, "start"]
- )
-
- def test_not_systemctl_failed(self, mock_systemctl):
-@@ -590,7 +590,7 @@
- lambda: lib.start_service(self.mock_runner, self.service),
- )
- self.mock_runner.run.assert_called_once_with(
-- [_service, self.service, "start"]
-+ [_rc_service, self.service, "start"]
- )
-
- def test_instance_systemctl(self, mock_systemctl):
-@@ -610,7 +610,7 @@
- self.mock_runner.run.return_value = ("Starting...", "", 0)
- lib.start_service(self.mock_runner, self.service, instance="test")
- self.mock_runner.run.assert_called_once_with(
-- [_service, self.service, "start"]
-+ [_rc_service, self.service, "start"]
- )
-
-
-@@ -644,7 +644,7 @@
- self.mock_runner.run.return_value = ("Stopping...", "", 0)
- lib.stop_service(self.mock_runner, self.service)
- self.mock_runner.run.assert_called_once_with(
-- [_service, self.service, "stop"]
-+ [_rc_service, self.service, "stop"]
- )
-
- def test_not_systemctl_failed(self, mock_systemctl):
-@@ -655,7 +655,7 @@
- lambda: lib.stop_service(self.mock_runner, self.service),
- )
- self.mock_runner.run.assert_called_once_with(
-- [_service, self.service, "stop"]
-+ [_rc_service, self.service, "stop"]
- )
-
- def test_instance_systemctl(self, mock_systemctl):
-@@ -671,7 +671,7 @@
- self.mock_runner.run.return_value = ("Stopping...", "", 0)
- lib.stop_service(self.mock_runner, self.service, instance="test")
- self.mock_runner.run.assert_called_once_with(
-- [_service, self.service, "stop"]
-+ [_rc_service, self.service, "stop"]
- )
-
-
-@@ -734,13 +734,13 @@
- mock_systemctl.return_value = False
- self.mock_runner.run.return_value = ("", "", 0)
- self.assertTrue(lib.is_service_enabled(self.mock_runner, self.service))
-- self.mock_runner.run.assert_called_once_with([_chkconfig, self.service])
-+ self.mock_runner.run.assert_called_once_with([_rc_config, self.service])
-
- def test_not_systemctl_disabled(self, mock_systemctl):
- mock_systemctl.return_value = False
- self.mock_runner.run.return_value = ("", "", 3)
- self.assertFalse(lib.is_service_enabled(self.mock_runner, self.service))
-- self.mock_runner.run.assert_called_once_with([_chkconfig, self.service])
-+ self.mock_runner.run.assert_called_once_with([_rc_config, self.service])
-
-
- @mock.patch("pcs.lib.external.is_systemctl")
-@@ -770,7 +770,7 @@
- self.mock_runner.run.return_value = ("is running", "", 0)
- self.assertTrue(lib.is_service_running(self.mock_runner, self.service))
- self.mock_runner.run.assert_called_once_with(
-- [_service, self.service, "status"]
-+ [_rc_service, self.service, "status"]
- )
-
- def test_not_systemctl_not_running(self, mock_systemctl):
-@@ -778,7 +778,7 @@
- self.mock_runner.run.return_value = ("is stopped", "", 3)
- self.assertFalse(lib.is_service_running(self.mock_runner, self.service))
- self.mock_runner.run.assert_called_once_with(
-- [_service, self.service, "status"]
-+ [_rc_service, self.service, "status"]
- )
-
-
-@@ -942,14 +942,14 @@
- ["pcsd", "sbd", "pacemaker"],
- )
- self.assertEqual(mock_is_systemctl.call_count, 1)
-- self.mock_runner.run.assert_called_once_with([_chkconfig])
-+ self.mock_runner.run.assert_called_once_with([_rc_config])
-
- def test_failed(self, mock_is_systemctl):
- mock_is_systemctl.return_value = False
- self.mock_runner.run.return_value = ("stdout", "failed", 1)
- self.assertEqual(lib.get_non_systemd_services(self.mock_runner), [])
- self.assertEqual(mock_is_systemctl.call_count, 1)
-- self.mock_runner.run.assert_called_once_with([_chkconfig])
-+ self.mock_runner.run.assert_called_once_with([_rc_config])
-
- def test_systemd(self, mock_is_systemctl):
- mock_is_systemctl.return_value = True
diff --git a/sys-cluster/pcs/files/openrc-0.10.8.patch b/sys-cluster/pcs/files/openrc-0.10.8.patch
index 5a1261002..905d700c3 100644
--- a/sys-cluster/pcs/files/openrc-0.10.8.patch
+++ b/sys-cluster/pcs/files/openrc-0.10.8.patch
@@ -1,5 +1,5 @@
---- a/pcs-0.10.8/pcs/lib/external.py
-+++ b/pcs-0.10.8/pcs/lib/external.py
+--- a/pcs/lib/external.py
++++ b/pcs/lib/external.py
@@ -13,8 +13,8 @@
from pcs.lib.errors import LibraryError
@@ -81,8 +81,8 @@
if return_code != 0:
return []
---- a/pcs-0.10.8/pcs/settings_default.py
-+++ b/pcs-0.10.8/pcs/settings_default.py
+--- a/pcs/settings_default.py
++++ b/pcs/settings_default.py
@@ -1,8 +1,8 @@
import os.path
@@ -112,8 +112,8 @@
# this limit is also mentioned in docs, change there as well
sbd_max_device_num = 3
# message types are also mentioned in docs, change there as well
---- a/pcs-0.10.8/pcs/settings.py.debian
-+++ b/pcs-0.10.8/pcs/settings.py.debian
+--- a/pcs/settings.py.debian
++++ b/pcs/settings.py.debian
@@ -1,10 +1,10 @@
from pcs.settings_default import *
-service_binary = "/usr/sbin/service"
@@ -130,8 +130,8 @@
pcsd_exec_location = "/usr/share/pcsd/"
pcsd_gem_path = None
pcsd_config = "/etc/default/pcsd"
---- a/pcs-0.10.8/pcs/utils.py
-+++ b/pcs-0.10.8/pcs/utils.py
+--- a/pcs/utils.py
++++ b/pcs/utils.py
@@ -2187,7 +2187,7 @@
)
else:
@@ -150,8 +150,8 @@
)
return join_multilines([stderr, stdout]), retval
---- a/pcs-0.10.8/pcsd/pcs.rb
-+++ b/pcs-0.10.8/pcsd/pcs.rb
+--- a/pcsd/pcs.rb
++++ b/pcsd/pcs.rb
@@ -1708,11 +1708,22 @@
def is_service_enabled?(service)
if ISSYSTEMCTL
@@ -233,8 +233,8 @@
end
_, _, retcode = run_cmd(PCSAuth.getSuperuserAuth(), *cmd)
return (retcode == 0)
---- a/pcs-0.10.8/pcsd/settings.rb
-+++ b/pcs-0.10.8/pcsd/settings.rb
+--- a/pcsd/settings.rb
++++ b/pcsd/settings.rb
@@ -3,7 +3,7 @@
PCSD_EXEC_LOCATION = '/usr/lib/pcsd/'
PCSD_VAR_LOCATION = '/var/lib/pcsd/'
@@ -244,8 +244,8 @@
CRT_FILE = PCSD_VAR_LOCATION + 'pcsd.crt'
KEY_FILE = PCSD_VAR_LOCATION + 'pcsd.key'
---- a/pcs-0.10.8/pcsd/settings.rb.debian
-+++ b/pcs-0.10.8/pcsd/settings.rb.debian
+--- a/pcsd/settings.rb.debian
++++ b/pcsd/settings.rb.debian
@@ -3,7 +3,7 @@
PCSD_EXEC_LOCATION = '/usr/share/pcsd/'
PCSD_VAR_LOCATION = '/var/lib/pcsd/'
@@ -255,8 +255,8 @@
CRT_FILE = PCSD_VAR_LOCATION + 'pcsd.crt'
KEY_FILE = PCSD_VAR_LOCATION + 'pcsd.key'
---- a/pcs-0.10.8/pcs_test/tier0/lib/test_external.py
-+++ b/pcs-0.10.8/pcs_test/tier0/lib/test_external.py
+--- a/pcs_test/tier0/lib/test_external.py
++++ b/pcs_test/tier0/lib/test_external.py
@@ -16,8 +16,8 @@
import pcs.lib.external as lib
diff --git a/sys-cluster/pcs/files/pcsd-daemon.service.patch b/sys-cluster/pcs/files/pcsd-daemon.service.patch
index ab615c366..98f27716d 100644
--- a/sys-cluster/pcs/files/pcsd-daemon.service.patch
+++ b/sys-cluster/pcs/files/pcsd-daemon.service.patch
@@ -1,5 +1,5 @@
---- a/pcs-0.10.8/pcsd/pcsd-ruby.service 2021-02-01 09:22:26.000000000 -0000
-+++ b/pcs-0.10.8/pcsd/pcsd-ruby.service 2021-04-11 14:13:00.176650050 -0000
+--- a/pcsd/pcsd-ruby.service
++++ b/pcsd/pcsd-ruby.service
@@ -5,13 +5,12 @@
Requires=network-online.target
After=network-online.target
diff --git a/sys-cluster/pcs/pcs-0.10.7.ebuild b/sys-cluster/pcs/pcs-0.10.7.ebuild
deleted file mode 100644
index c4cfeedbd..000000000
--- a/sys-cluster/pcs/pcs-0.10.7.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-USE_RUBY="ruby25 ruby26"
-inherit distutils-r1 ruby-ng systemd
-
-DESCRIPTION="Pacemaker/Corosync Configuration System"
-HOMEPAGE="https://github.com/ClusterLabs/pcs"
-SRC_URI="https://github.com/ClusterLabs/pcs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="snmp systemd"
-
-DEPEND="
- dev-libs/libffi
- media-libs/fontconfig
- sys-apps/coreutils
-"
-RDEPEND="
- ${DEPEND}
- dev-libs/openssl
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/dacite[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pycurl[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=sys-cluster/corosync-3.0
- >=sys-cluster/pacemaker-2.0
- sys-libs/pam
- sys-process/psmisc
- >=www-servers/tornado-6.0[${PYTHON_USEDEP}]
- <www-servers/tornado-7.0[${PYTHON_USEDEP}]
-"
-
-ruby_add_rdepend "
- dev-ruby/backports
- dev-ruby/bundler
- dev-ruby/ethon
- dev-ruby/highline
- dev-ruby/json
- dev-ruby/multi_json
- dev-ruby/open4
- dev-ruby/rack
- dev-ruby/rack-protection
- dev-ruby/rack-test
- dev-ruby/rubygems
- dev-ruby/sinatra
- www-servers/thin
- dev-ruby/thor
- dev-ruby/tilt
-"
-
-PATCHES=( "${FILESDIR}/remove-ruby-bundle-path.patch" "${FILESDIR}/openrc-0.10.7.patch" )
-
-S="${WORKDIR}/all/${P}"
-
-src_compile() {
- return
-}
-
-src_install() {
- # pre-create directory that is needed by 'make install'
- dodir "/usr/lib/pcs"
- # install files using 'make install'
- emake install \
- SYSTEMCTL_OVERRIDE=$(use systemd) \
- DESTDIR="${D}" \
- CONF_DIR="/etc/default/" \
- PREFIX="${EPREFIX}/usr/" \
- BUNDLE_INSTALL_PYAGENTX=false \
- BUNDLE_TO_INSTALL=false \
- BUILD_GEMS=false
-
- # mark log directories to be kept
- keepdir /var/log/pcsd
- keepdir /var/lib/pcsd
-
- # symlink the /usr/lib/pcs/pcs to /usr/sbin/pcs for pcsd
- dosym ../../sbin/pcs "${EPREFIX}/usr/lib/pcs/pcs"
-
- # use Debian style systemd unit (with config in /etc/default/pcsd)
- if use systemd ; then
- systemd_newunit "${S}/pcsd/pcsd.service.debian" "pcsd.service"
- systemd_newunit "${S}/pcsd/pcsd-ruby.service" "pcsd-daemon.service"
- fi
- # custom service file for openRC
- newinitd "${FILESDIR}/pcsd.initd" pcsd || die
- newinitd "${FILESDIR}/pcsd-daemon.initd" pcsd-daemon || die
-
- # move config files to right places - we use debian-style /etc/default
- cp -a "${S}/pcs/settings.py.debian" "${D}/usr/lib/pcs/settings.py"
- cp -a "${S}/pcsd/settings.rb.debian" "${D}/usr/lib/pcsd/settings.rb"
-
- # unless support for SNMP was requested remove SNMP related files
- if ! use snmp; then
- rm -rf "${D}/usr/share/snmp"
- rm -rf "${D}/usr/lib64/python*/site-packages/pcs/snmp" #FIXME
- rm "${D}/usr/share/man/man8/pcs_snmp_agent.8"
- rm "${D}/usr/lib/pcs/pcs_snmp_agent"
- rm "${D}/etc/default/pcs_snmp_agent"
- fi
-
- python_foreach_impl python_optimize
-}
diff --git a/sys-cluster/pcs/pcs-0.10.8-r2.ebuild b/sys-cluster/pcs/pcs-0.10.8-r3.ebuild
index d212d0c3f..b348a3848 100644
--- a/sys-cluster/pcs/pcs-0.10.8-r2.ebuild
+++ b/sys-cluster/pcs/pcs-0.10.8-r3.ebuild
@@ -3,15 +3,16 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..9} )
USE_RUBY="ruby25 ruby26"
+
inherit python-single-r1 ruby-ng systemd
DESCRIPTION="Pacemaker/Corosync Configuration System"
HOMEPAGE="https://github.com/ClusterLabs/pcs"
SRC_URI="https://github.com/ClusterLabs/pcs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
+S="${WORKDIR}/all/${P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
@@ -43,12 +44,12 @@ RDEPEND="
sys-libs/pam
sys-process/psmisc
"
+
PATCHES=(
"${FILESDIR}/remove-ruby-bundle-path.patch"
"${FILESDIR}/openrc-${PV}.patch"
"${FILESDIR}/pcsd-daemon.service.patch"
)
-S="${WORKDIR}/all/${P}"
ruby_add_rdepend "
dev-ruby/backports
diff --git a/sys-cluster/pcs/pcs-0.10.8.ebuild b/sys-cluster/pcs/pcs-0.10.8.ebuild
deleted file mode 100644
index 3a7f366d9..000000000
--- a/sys-cluster/pcs/pcs-0.10.8.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-USE_RUBY="ruby25 ruby26"
-inherit distutils-r1 ruby-ng systemd
-
-DESCRIPTION="Pacemaker/Corosync Configuration System"
-HOMEPAGE="https://github.com/ClusterLabs/pcs"
-SRC_URI="https://github.com/ClusterLabs/pcs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="snmp systemd"
-
-DEPEND="
- dev-libs/libffi
- media-libs/fontconfig
- sys-apps/coreutils
-"
-RDEPEND="
- ${DEPEND}
- dev-libs/openssl
- dev-python/distro[${PYTHON_USEDEP}]
- dev-python/dacite[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pycurl[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=sys-cluster/corosync-3.0
- >=sys-cluster/pacemaker-2.0
- sys-libs/pam
- sys-process/psmisc
- >=www-servers/tornado-6.0[${PYTHON_USEDEP}]
- <www-servers/tornado-7.0[${PYTHON_USEDEP}]
-"
-
-ruby_add_rdepend "
- dev-ruby/backports
- dev-ruby/bundler
- dev-ruby/ethon
- dev-ruby/highline
- dev-ruby/json
- dev-ruby/multi_json
- dev-ruby/open4
- dev-ruby/rack
- dev-ruby/rack-protection
- dev-ruby/rack-test
- dev-ruby/rubygems
- dev-ruby/sinatra
- dev-ruby/thor
- dev-ruby/tilt
- www-servers/thin
-"
-
-PATCHES=( "${FILESDIR}/remove-ruby-bundle-path.patch" "${FILESDIR}/openrc-${PV}.patch" )
-
-S="${WORKDIR}/all/${P}"
-
-src_compile() {
- return
-}
-
-src_install() {
- # pre-create directory that is needed by 'make install'
- dodir "/usr/lib/pcs"
- # install files using 'make install'
- emake install \
- SYSTEMCTL_OVERRIDE=$(use systemd) \
- DESTDIR="${D}" \
- CONF_DIR="/etc/default/" \
- PREFIX="${EPREFIX}/usr/" \
- BUNDLE_INSTALL_PYAGENTX=false \
- BUNDLE_TO_INSTALL=false \
- BUILD_GEMS=false
-
- # mark log directories to be kept
- keepdir /var/log/pcsd
- keepdir /var/lib/pcsd
-
- # symlink the /usr/lib/pcs/pcs to /usr/sbin/pcs for pcsd
- dosym ../../sbin/pcs "${EPREFIX}/usr/lib/pcs/pcs"
-
- # use Debian style systemd unit (with config in /etc/default/pcsd)
- if use systemd ; then
- systemd_newunit "${S}/pcsd/pcsd.service.debian" "pcsd.service"
- systemd_newunit "${S}/pcsd/pcsd-ruby.service" "pcsd-daemon.service"
- fi
- # custom service file for openRC
- newinitd "${FILESDIR}/pcsd.initd" pcsd || die
- newinitd "${FILESDIR}/pcsd-daemon.initd" pcsd-daemon || die
-
- # move config files to right places - we use debian-style /etc/default
- cp -a "${S}/pcs/settings.py.debian" "${D}/usr/lib/pcs/settings.py"
- cp -a "${S}/pcsd/settings.rb.debian" "${D}/usr/lib/pcsd/settings.rb"
-
- # unless support for SNMP was requested remove SNMP related files
- if ! use snmp; then
- rm -rf "${D}/usr/share/snmp"
- rm -rf "${D}/usr/lib64/python*/site-packages/pcs/snmp" #FIXME
- rm "${D}/usr/share/man/man8/pcs_snmp_agent.8"
- rm "${D}/usr/lib/pcs/pcs_snmp_agent"
- rm "${D}/etc/default/pcs_snmp_agent"
- fi
-
- python_foreach_impl python_optimize
-}