aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2020-07-22 16:13:43 +0200
committerMatthias Coppens <coppens.matthias.abc@gmail.com>2020-07-22 16:17:51 +0200
commitfff6ba4178ff7e1814f27ecec055c6669870484b (patch)
treefaf16eb867a4ea9acc67e2c8546d2ab02a2d0637
parentgames-engines/boxtron: ebuild improvements (diff)
downloadguru-fff6ba41.tar.gz
guru-fff6ba41.tar.bz2
guru-fff6ba41.zip
media-gfx/memethesis-cli: New package
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com>
-rw-r--r--media-gfx/memethesis-cli/Manifest1
-rw-r--r--media-gfx/memethesis-cli/files/prompt.patch13
-rw-r--r--media-gfx/memethesis-cli/memethesis-cli-3.2.1.ebuild37
-rw-r--r--media-gfx/memethesis-cli/memethesis-cli-9999.ebuild35
-rw-r--r--media-gfx/memethesis-cli/metadata.xml8
5 files changed, 94 insertions, 0 deletions
diff --git a/media-gfx/memethesis-cli/Manifest b/media-gfx/memethesis-cli/Manifest
new file mode 100644
index 000000000..ff0031be2
--- /dev/null
+++ b/media-gfx/memethesis-cli/Manifest
@@ -0,0 +1 @@
+DIST memethesis-cli-3.2.1.tar.gz 2708404 BLAKE2B fb31de388f1f602f5f7e24a5e10ebe59c5ac628da05acc37c8b4204736f6dba9573e3b9ed0966b09b046fee3066a156807e983a081103a0d4258d9794b035b54 SHA512 d4737ae5bbbd1e32b0707cfadd5d521e2eabc567105218122dea31ab45b8ac57e3b677c1c83d76bf85605be82e3c06c2dd746141a153234a787140068eada183
diff --git a/media-gfx/memethesis-cli/files/prompt.patch b/media-gfx/memethesis-cli/files/prompt.patch
new file mode 100644
index 000000000..7eac4e7b1
--- /dev/null
+++ b/media-gfx/memethesis-cli/files/prompt.patch
@@ -0,0 +1,13 @@
+diff --git a/memethesis/interactive.py b/memethesis/interactive.py
+index aede6dc..4c069c6 100644
+--- a/memethesis/interactive.py
++++ b/memethesis/interactive.py
+@@ -1,7 +1,7 @@
+ import sys
+ import re
+ import yaml
+-from PyInquirer import prompt
++from PyInquirer.prompt import prompt
+ from .fancyprint import color, style
+ from .memethesizers import *
+ from .fonts import FONTS
diff --git a/media-gfx/memethesis-cli/memethesis-cli-3.2.1.ebuild b/media-gfx/memethesis-cli/memethesis-cli-3.2.1.ebuild
new file mode 100644
index 000000000..b232bbcac
--- /dev/null
+++ b/media-gfx/memethesis-cli/memethesis-cli-3.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/fakefred/${PN}"
+case "${PV}" in
+ 9999)
+ inherit git-r3
+ ;;
+ *)
+ SRC_URI="${EGIT_REPO_URI}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ # pyinquirer's latest version is outdated, so memethesis depends
+ # on a live ebuild for pyinquirer at the moment
+ KEYWORDS=""
+esac
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Create memes from the terminal"
+HOMEPAGE="${EGIT_REPO_URI}"
+LICENSE="GPL-3"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/prompt.patch" )
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pillow[truetype,${PYTHON_USEDEP}]
+ >dev-python/pyinquirer-1.0.3[${PYTHON_USEDEP}]
+ dev-python/colored[${PYTHON_USEDEP}]')
+ >=media-gfx/imagemagick-7"
+BDEPEND="${RDEPEND}"
diff --git a/media-gfx/memethesis-cli/memethesis-cli-9999.ebuild b/media-gfx/memethesis-cli/memethesis-cli-9999.ebuild
new file mode 100644
index 000000000..53700b7f6
--- /dev/null
+++ b/media-gfx/memethesis-cli/memethesis-cli-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/fakefred/${PN}"
+case "${PV}" in
+ 9999)
+ inherit git-r3
+ ;;
+ *)
+ SRC_URI="${EGIT_REPO_URI}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+esac
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Create memes from the terminal"
+HOMEPAGE="${EGIT_REPO_URI}"
+LICENSE="GPL-3"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/prompt.patch" )
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pillow[truetype,${PYTHON_USEDEP}]
+ >dev-python/pyinquirer-1.0.3[${PYTHON_USEDEP}]
+ dev-python/colored[${PYTHON_USEDEP}]')
+ >=media-gfx/imagemagick-7"
+BDEPEND="${RDEPEND}"
diff --git a/media-gfx/memethesis-cli/metadata.xml b/media-gfx/memethesis-cli/metadata.xml
new file mode 100644
index 000000000..e40cebf35
--- /dev/null
+++ b/media-gfx/memethesis-cli/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>coppens.matthias.abc@gmail.com</email>
+ <name>Matthias Coppens</name>
+ </maintainer>
+</pkgmetadata>