aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber+gentoo@sysrq.in>2021-05-26 03:44:03 +0500
committerAnna Vyalkova <cyber+gentoo@sysrq.in>2021-05-26 06:53:15 +0500
commit6d977ecde366852ebb137ea7dacd3ab6825f8736 (patch)
treef72446638a38b26a0a5f0a9b0591d71b7570e683 /app-accessibility/rhvoice
parentgames-fps/quakespasm: New Package (diff)
downloadguru-6d977ecde366852ebb137ea7dacd3ab6825f8736.tar.gz
guru-6d977ecde366852ebb137ea7dacd3ab6825f8736.tar.bz2
guru-6d977ecde366852ebb137ea7dacd3ab6825f8736.zip
app-accessibility/rhvoice: unbundle rapidxml
Bug in dev-libs/rapidxml is resolved now, so using bundled version is not necessary anymore. https://bugs.gentoo.org/791328 Signed-off-by: Anna Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-accessibility/rhvoice')
-rw-r--r--app-accessibility/rhvoice/rhvoice-1.2.4.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-accessibility/rhvoice/rhvoice-1.2.4.ebuild b/app-accessibility/rhvoice/rhvoice-1.2.4.ebuild
index a467dbdff9..a550f7b13c 100644
--- a/app-accessibility/rhvoice/rhvoice-1.2.4.ebuild
+++ b/app-accessibility/rhvoice/rhvoice-1.2.4.ebuild
@@ -10,16 +10,16 @@ DESCRIPTION="TTS engine with extended languages support (including Russian)"
HOMEPAGE="https://rhvoice.su https://github.com/RHVoice/RHVoice"
SRC_URI="
https://github.com/${MY_PN}/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
- l10n_en? ( https://github.com/RHVoice/evgeniy-eng/archive/refs/tags/4.0.tar.gz -> rhvoice-evgeniy-eng-4.0.tar.gz )
+ l10n_en? ( https://github.com/${MY_PN}/evgeniy-eng/archive/refs/tags/4.0.tar.gz -> rhvoice-evgeniy-eng-4.0.tar.gz )
l10n_ru? (
- https://github.com/RHVoice/evgeniy-rus/archive/refs/tags/4.0.tar.gz -> rhvoice-evgeniy-rus-4.0.tar.gz
- https://github.com/RHVoice/victoria-rus/archive/refs/tags/4.0.tar.gz -> rhvoice-victoria-4.0.tar.gz
+ https://github.com/${MY_PN}/evgeniy-rus/archive/refs/tags/4.0.tar.gz -> rhvoice-evgeniy-rus-4.0.tar.gz
+ https://github.com/${MY_PN}/victoria-rus/archive/refs/tags/4.0.tar.gz -> rhvoice-victoria-4.0.tar.gz
)
"
S="${WORKDIR}/${MY_PN}-${PV}"
CMAKE_REMOVE_MODULES_LIST="Hardening VersionFromGit"
-LICENSE="l10n_pt-BR? ( CC-BY-SA-4.0 ) BSD GPL-2 GPL-3+ LGPL-2.1+ MIT"
+LICENSE="l10n_pt-BR? ( CC-BY-SA-4.0 ) BSD GPL-2 GPL-3+ LGPL-2.1+"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="ao bindist cli client portaudio +pulseaudio +server +speech-dispatcher utils"
@@ -54,6 +54,7 @@ RDEPEND="
"
BDEPEND="${DEPEND}
dev-cpp/cli11
+ dev-libs/rapidxml
dev-libs/utfcpp
"
REQUIRED_USE="|| ( ao portaudio pulseaudio )"
@@ -91,8 +92,9 @@ src_prepare() {
sed 's|/systemd/system||' \
-i src/service/CMakeLists.txt || die
- rm -r src/third-party/{sonic,tclap,utf8} || die
- sed "/sonic/d" -i src/third-party/CMakeLists.txt || die
+ sed -e "/sonic/d" \
+ -e "/set(RAPIDXML_INCLUDE_DIR/d" \
+ -i src/third-party/CMakeLists.txt || die
sed "/set(UTF8_INCLUDE_DIR/d" -i src/CMakeLists.txt || die
sed 's/ "RHVoice_question_match"//' \
@@ -136,10 +138,9 @@ src_configure() {
-DWITH_PULSE=$(usex pulseaudio)
-DWITH_PORTAUDIO=$(usex portaudio)
# src/third-party/CMakeLists.txt
- -DRAPIDXML_INCLUDE_DIR="${S}"/src/third-party/rapidxml
+ -DRAPIDXML_INCLUDE_DIR=/usr/include/rapidxml
-DUTF8_INCLUDE_DIR=/usr/include/utf8cpp
)
- append-cppflags -std=gnu++11
cmake_src_configure
}