aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-11-08 22:17:14 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-11-08 22:19:50 +0500
commitb35c40c2fd6e98f28de0641d30b7849a5a46c08b (patch)
tree690ed438a3d2909468f31013ebe23f4e91217d4d /app-accessibility/rhvoice
parentapp-misc/watchexec: remove old (diff)
downloadguru-b35c40c2fd6e98f28de0641d30b7849a5a46c08b.tar.gz
guru-b35c40c2fd6e98f28de0641d30b7849a5a46c08b.tar.bz2
guru-b35c40c2fd6e98f28de0641d30b7849a5a46c08b.zip
app-accessibility/rhvoice: keep Hardening.cmake
Turns out it has options to not add weird flags. Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-accessibility/rhvoice')
-rw-r--r--app-accessibility/rhvoice/rhvoice-1.4.2-r1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/app-accessibility/rhvoice/rhvoice-1.4.2-r1.ebuild b/app-accessibility/rhvoice/rhvoice-1.4.2-r1.ebuild
index f593a64fa8..e23f725d7b 100644
--- a/app-accessibility/rhvoice/rhvoice-1.4.2-r1.ebuild
+++ b/app-accessibility/rhvoice/rhvoice-1.4.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-CMAKE_REMOVE_MODULES_LIST=( Hardening VersionFromGit )
+CMAKE_REMOVE_MODULES_LIST=( VersionFromGit )
inherit cmake
DESCRIPTION="TTS engine with extended languages support (including Russian)"
@@ -75,15 +75,11 @@ src_prepare() {
-i src/third-party/mage/CMakeLists.txt || die
sed -e "/include(VersionFromGit)/d" \
- -e "/include(Hardening)/d" \
-e "/find_package(Sanitizers)/d" \
-e "/getVersionFromGit/d" \
- -e "/harden/d" \
-i CMakeLists.txt || die
sed -e "/add_sanitizers/d" \
- -e "/harden/d" \
- -i src/*/CMakeLists.txt \
- -i src/third-party/*/CMakeLists.txt || die
+ -i src/*/CMakeLists.txt src/third-party/*/CMakeLists.txt || die
use l10n_en || delete_voices alan bdl clb evgeniy-eng slt
use l10n_eo || delete_voices spomenka
@@ -116,6 +112,9 @@ src_configure() {
# src/third-party/CMakeLists.txt
#-DRAPIDXML_INCLUDE_DIR=/usr/include/rapidxml
-DUTF8_INCLUDE_DIR=/usr/include/utf8cpp
+ # Hardening.cmake: don't mess with flags
+ -DHARDENING_COMPILE_FLAGS=
+ -DHARDENING_LINK_FLAGS=
)
cmake_src_configure