aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Willem Fernhout <hfern@fernhout.info>2021-01-17 12:10:37 +0100
committerJohannes Willem Fernhout <hfern@fernhout.info>2021-01-17 12:36:58 +0100
commitfda0861b6017361402a1bdc127ce3dea8bdae06a (patch)
tree5b897bd5e1782dadaaa596ced151eadd6396d8a4 /app-admin
parentgames-action/multimc: fix build with clang (-Werror) (diff)
downloadguru-fda0861b6017361402a1bdc127ce3dea8bdae06a.tar.gz
guru-fda0861b6017361402a1bdc127ce3dea8bdae06a.tar.bz2
guru-fda0861b6017361402a1bdc127ce3dea8bdae06a.zip
app-admin/krapplet: Version bump
Bug fix and documentation update Signed-off-by: Johannes Willem Fernhout <hfern@fernhout.info>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/krapplet/Manifest1
-rw-r--r--app-admin/krapplet/krapplet-0.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/krapplet/Manifest b/app-admin/krapplet/Manifest
index 6030395f0..5656c5f63 100644
--- a/app-admin/krapplet/Manifest
+++ b/app-admin/krapplet/Manifest
@@ -1 +1,2 @@
DIST krapplet-0.1.0.tar.gz 30262 BLAKE2B 26e6f08f6fb2dc6ebde9a328eb0a7c016debeec472fd89c02c2a1e8b86eb96834d731911a13d690f2a6c0754a109456eb645538472d1ba3e17f725e185598971 SHA512 dbc23cf44e059a57cd026ffa21a98cc10bf188da66c23f10a719740f8b470c8372f0298c0d4b9c6085bca8e54ad66784dc480ebfd2d8a6813a682ee8ac968c14
+DIST krapplet-0.2.0.tar.gz 35908 BLAKE2B 264050b1803f3985b6fa98ba67370d9306c15a1545239fa366eef5966224c8b143b66fe9d6a814bcf82e29a1aa4154c998747515764a71fd249ae9254a34681e SHA512 34466d94666b374050bdf990444e7cf31a89f18c2f573b978745e448fe899615addc498d629994ee68082f6dc80798c8e4697c261adbe4aaade000a7dae7cf40
diff --git a/app-admin/krapplet/krapplet-0.2.0.ebuild b/app-admin/krapplet/krapplet-0.2.0.ebuild
new file mode 100644
index 000000000..73ea8d492
--- /dev/null
+++ b/app-admin/krapplet/krapplet-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="Krapplet (keyring applet): a password manager based on gnome-keyring."
+HOMEPAGE="https://gitlab.com/hfernh/krapplet https://pypi.org/project/krapplet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+BDEPEND=${RDEPEND}
+
+# Upstream does not provide any test suite.
+RESTRICT="test"
+
+RDEPEND="
+ x11-libs/gtk+:3
+ dev-libs/glib
+ dev-libs/gobject-introspection
+ dev-python/secretstorage"
+
+DEPEND="${RDEPEND}"