aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-04-17 02:26:02 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2021-04-17 02:26:56 +0200
commitd87046c51059bed0f6dfb5f4fe13c91244b86d59 (patch)
treee5c3af1549588809401b37dbe05dc8f531c235ea /app-crypt
parentsys-cluster/er: new version (diff)
downloadguru-d87046c51059bed0f6dfb5f4fe13c91244b86d59.tar.gz
guru-d87046c51059bed0f6dfb5f4fe13c91244b86d59.tar.bz2
guru-d87046c51059bed0f6dfb5f4fe13c91244b86d59.zip
app-crypt/tomb: freedesktop stuff
please review, not sure about all that xdg things Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tomb/tomb-2.9-r3.ebuild (renamed from app-crypt/tomb/tomb-2.9-r2.ebuild)39
1 files changed, 38 insertions, 1 deletions
diff --git a/app-crypt/tomb/tomb-2.9-r2.ebuild b/app-crypt/tomb/tomb-2.9-r3.ebuild
index 226d8e67c..5dd083f3d 100644
--- a/app-crypt/tomb/tomb-2.9-r2.ebuild
+++ b/app-crypt/tomb/tomb-2.9-r3.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit qmake-utils
+inherit qmake-utils xdg
MYP="${P^}"
DESCRIPTION="Tomb :: File Encryption on GNU/Linux"
@@ -102,16 +102,45 @@ src_install() {
popd || die
fi
+ #qt tray
if use tray ; then
pushd extras/qt-tray || die
dobin tomb-qt-tray
popd || die
fi
+ #kdf programs
pushd extras/kdf-keys || die
emake install
popd || die
+ #is there an eclass for this?
+ #pixmap
+ insinto /usr/share/pixmaps
+ doins extras/gtk-tray/monmort.xpm
+ pushd extras/desktop
+ #copied from install.zsh
+ #mime types
+ xdg-mime install dyne-tomb.xml
+ xdg-icon-resource install --context mimetypes --size 32 monmort.xpm monmort
+ xdg-icon-resource install --size 32 monmort.xpm dyne-monmort
+ #desktop
+ insinto /usr/share/applications
+ doins tomb.desktop
+ #menu
+ insinto /etc/menu
+ doins tomb
+ #mime info
+ insinto /usr/share/mime-info
+ doins tomb.mime
+ doins tomb.keys
+ insinto /usr/lib/mime/packages
+ newins tomb.mimepkg tomb
+ #application entry
+ insinto /usr/share/application-registry
+ doins tomb.applications
+ popd
+
#documentation
einstalldocs
cd doc/literate || die
@@ -125,3 +154,11 @@ src_test() {
pushd extras/kdf-keys || die
emake test
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}