aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-04-16 20:07:42 +0200
committerMarco Scardovi <marco@scardovi.com>2021-04-16 20:08:06 +0200
commit2d4945307e18658bfbf37fd93fcd4082328265fe (patch)
treed5df3e615cd7d4297dd170f5fa0a83ffc21c1e98 /app-editors
parentgames-action/ATLauncher: install jar without version (diff)
downloadguru-2d4945307e18658bfbf37fd93fcd4082328265fe.tar.gz
guru-2d4945307e18658bfbf37fd93fcd4082328265fe.tar.bz2
guru-2d4945307e18658bfbf37fd93fcd4082328265fe.zip
app-editors/atom-bin: makes everything mandatory
Closes: https://bugs.gentoo.org/783186 Closes: https://bugs.gentoo.org/783183 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/atom-bin/atom-bin-1.56.0-r3.ebuild (renamed from app-editors/atom-bin/atom-bin-1.56.0-r2.ebuild)57
1 files changed, 25 insertions, 32 deletions
diff --git a/app-editors/atom-bin/atom-bin-1.56.0-r2.ebuild b/app-editors/atom-bin/atom-bin-1.56.0-r3.ebuild
index 37324372b..821471077 100644
--- a/app-editors/atom-bin/atom-bin-1.56.0-r2.ebuild
+++ b/app-editors/atom-bin/atom-bin-1.56.0-r3.ebuild
@@ -12,9 +12,7 @@ SRC_URI="https://github.com/atom/atom/releases/download/v${PV}/atom-amd64.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-
-IUSE="alsa cups ssl test X"
-RESTRICT="!test? ( test )"
+RESTRICT="test"
S="${WORKDIR}/atom-${PV}-amd64"
@@ -24,33 +22,29 @@ RDEPEND="
app-crypt/libsecret
dev-libs/atk
dev-libs/nss
+ dev-libs/openssl
+ dev-libs/openssl-compat
dev-vcs/git
- alsa? ( media-libs/alsa-lib )
- cups? ( net-print/cups )
- ssl? (
- dev-libs/openssl
- dev-libs/openssl-compat
- )
- X? (
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/gtk+
- x11-libs/libnotify
- x11-libs/libX11
- x11-libs/libxcb
- x11-libs/libXcomposite
- x11-libs/libXcursor
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXi
- x11-libs/libxkbfile
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXScrnSaver
- x11-libs/libXtst
- x11-libs/pango
- )
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
"
QA_PREBUILT="/opt/${PN}/*"
@@ -70,9 +64,7 @@ src_install(){
# I will use only npm provided with package itself
# as nodejs is not required to make it working (and it is really big).
- fperms +x /opt/"${PN}"/resources/app/apm/bin/apm
- fperms +x /opt/"${PN}"/resources/app/apm/bin/node
- fperms +x /opt/"${PN}"/resources/app/apm/bin/npm
+ fperms +x /opt/"${PN}"/resources/app/apm/bin/*
doicon atom.png
make_desktop_entry "/opt/atom-bin/atom %U" "Atom" "atom" \
@@ -85,6 +77,7 @@ src_install(){
}
pkg_postinst(){
+ xdg_desktop_database_update
optfeature_header "If you want to use atom-beautify please install following packages:"
optfeature "python code beautifier" dev-python/autopep8
optfeature "python code beautifier" dev-python/black