aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans Fredrik Nordhaug <hansfn@gmail.com>2021-03-09 16:52:12 +0100
committerHans Fredrik Nordhaug <hansfn@gmail.com>2021-03-09 16:52:29 +0100
commit6faaecf13f448a2c13d3f949d26066d742e37660 (patch)
treef48fc70d3fea24ddfb05e584f0907cc2d61b096f /app-editors
parentsys-fs/dwarfs: new version 0.4.0 (diff)
downloadguru-6faaecf13f448a2c13d3f949d26066d742e37660.tar.gz
guru-6faaecf13f448a2c13d3f949d26066d742e37660.tar.bz2
guru-6faaecf13f448a2c13d3f949d26066d742e37660.zip
app-editors/featherpad: version bump 0.18.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans Fredrik Nordhaug <hansfn@gmail.com>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/featherpad/Manifest1
-rw-r--r--app-editors/featherpad/featherpad-0.18.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
index 3709d6e9b..e5df9fdc0 100644
--- a/app-editors/featherpad/Manifest
+++ b/app-editors/featherpad/Manifest
@@ -1 +1,2 @@
DIST featherpad-0.17.2.tar.gz 921192 BLAKE2B 38d0520c918dbae0b46f2a6d1a3f553f28ef0351b017600d4cc21cce61eb69bf08a80c118dfb794af3489cbb10c93d59c2b8effc049eccbd57aaefc403bddb29 SHA512 39721faa4c0b5c0920c9fdcbfaafe864b6e649145ec8b51ea1f3ca3ec038119caaf0a812362e226fd4e699d0f385508f1fb12992b2219f995b8486779d06b872
+DIST featherpad-0.18.0.tar.gz 967643 BLAKE2B a8a84fa71232bdd9448ec4a9c921f8f452212dfb52ec518c3f340e9b600858a9cfca2d7729a0f58c9d1465b77bd28c836de78026c58ff94297de704e7bf670d8 SHA512 3e0d008792dd55bc5e57654f9b032f0a66a60c682499c684cfc3b182fdc57a654bb5fb195b458af66ddd8db929b31e7bfa789bd9bdf33d32454fbbcb090bcd91
diff --git a/app-editors/featherpad/featherpad-0.18.0.ebuild b/app-editors/featherpad/featherpad-0.18.0.ebuild
new file mode 100644
index 000000000..179b3541a
--- /dev/null
+++ b/app-editors/featherpad/featherpad-0.18.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg qmake-utils
+
+MY_P="${P/featherpad/FeatherPad}"
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-text/hunspell
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}