aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2020-03-12 20:55:42 +0100
committerDavid Roman <davidroman96@gmail.com>2020-03-12 20:56:29 +0100
commit68e34dda23f0fb4280796a269e9e927ff52c908e (patch)
tree6738f28cba36e3f8db15661c71f30248f1e2e345 /app-misc/telegram-send/telegram-send-0.25.ebuild
parentdev-python/python-telegram-bot: new package (diff)
downloadguru-68e34dda23f0fb4280796a269e9e927ff52c908e.tar.gz
guru-68e34dda23f0fb4280796a269e9e927ff52c908e.tar.bz2
guru-68e34dda23f0fb4280796a269e9e927ff52c908e.zip
app-misc/telegram-send: new package
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'app-misc/telegram-send/telegram-send-0.25.ebuild')
-rw-r--r--app-misc/telegram-send/telegram-send-0.25.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-misc/telegram-send/telegram-send-0.25.ebuild b/app-misc/telegram-send/telegram-send-0.25.ebuild
new file mode 100644
index 000000000..f762d1414
--- /dev/null
+++ b/app-misc/telegram-send/telegram-send-0.25.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Send messages and files over Telegram from the command-line."
+HOMEPAGE="https://www.rahielkasim.com/telegram-send/"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/python-telegram-bot[${PYTHON_USEDEP}]
+"