aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-06-22 18:43:24 +0200
committerMarco Scardovi <marco@scardovi.com>2021-06-22 18:43:24 +0200
commit08e92ea0dc25d5d00b07b57b550a725685bf1f91 (patch)
treed03a9db616e0e974dcc57b5ddc26b69c0d5b6719 /app-mobilephone
parentgui-wm/phosh: fix QA error for domenu (diff)
downloadguru-08e92ea0dc25d5d00b07b57b550a725685bf1f91.tar.gz
guru-08e92ea0dc25d5d00b07b57b550a725685bf1f91.tar.bz2
guru-08e92ea0dc25d5d00b07b57b550a725685bf1f91.zip
app-mobilephone/flashlight: add new package
flashlight is the flashlight app for pinephone/librem 5 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/flashlight/Manifest1
-rw-r--r--app-mobilephone/flashlight/files/60-flashlight.rules5
-rw-r--r--app-mobilephone/flashlight/files/90-flashlight.rules2
-rw-r--r--app-mobilephone/flashlight/flashlight-0.1.1-r1.ebuild32
-rw-r--r--app-mobilephone/flashlight/metadata.xml11
5 files changed, 51 insertions, 0 deletions
diff --git a/app-mobilephone/flashlight/Manifest b/app-mobilephone/flashlight/Manifest
new file mode 100644
index 000000000..8739b8f4f
--- /dev/null
+++ b/app-mobilephone/flashlight/Manifest
@@ -0,0 +1 @@
+DIST flashlight-0.1.1.tar.gz 20077 BLAKE2B c9ed29d034c5c7e91a87209236e153afbada4c0e098dba0e0ed8fa0f7b321d3ec693fe198de415031024f4a29437ba2986809f30009c5c09751d7800449a42af SHA512 ed8350bf75f5638c36ba070dee7f5aa0455fcde5ed4ecc63ff7a27578d34e382e16b2998e25898e972b95b5307af58de14b96ee359bedfcee924f9b7e865dcd6
diff --git a/app-mobilephone/flashlight/files/60-flashlight.rules b/app-mobilephone/flashlight/files/60-flashlight.rules
new file mode 100644
index 000000000..b9098a83c
--- /dev/null
+++ b/app-mobilephone/flashlight/files/60-flashlight.rules
@@ -0,0 +1,5 @@
+# SPDX-License-Identifier: GPL-3+
+#
+# This file is part of flashlight.
+
+SUBSYSTEM=="leds", KERNEL=="white:flash", ACTION=="add", RUN+="/bin/chmod -R a+w /sys%p"
diff --git a/app-mobilephone/flashlight/files/90-flashlight.rules b/app-mobilephone/flashlight/files/90-flashlight.rules
new file mode 100644
index 000000000..3aafcd21a
--- /dev/null
+++ b/app-mobilephone/flashlight/files/90-flashlight.rules
@@ -0,0 +1,2 @@
+SUBSYSTEM=="leds", ACTION=="add", KERNEL=="white:flash", \
+ RUN+="/bin/chmod 777 /sys/class/leds/%k/brightness"
diff --git a/app-mobilephone/flashlight/flashlight-0.1.1-r1.ebuild b/app-mobilephone/flashlight/flashlight-0.1.1-r1.ebuild
new file mode 100644
index 000000000..775fe6a04
--- /dev/null
+++ b/app-mobilephone/flashlight/flashlight-0.1.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson gnome2-utils udev
+
+MY_COMMIT="f5feb4b3d17bbf16171d716bbb8e28f3a84542ef"
+
+DESCRIPTION="It's a flashlight, what do you expect?"
+HOMEPAGE="https://gitlab.com/a-wai/flashlight.git"
+SRC_URI="https://gitlab.com/a-wai/flashlight/-/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+src_install() {
+ meson_src_install
+ udev_dorules "${FILESDIR}/60-flashlight.rules"
+ mv "${D}/usr/share/appdata" "${D}/usr/share/metainfo" || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/app-mobilephone/flashlight/metadata.xml b/app-mobilephone/flashlight/metadata.xml
new file mode 100644
index 000000000..a0b29038e
--- /dev/null
+++ b/app-mobilephone/flashlight/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marco@scardovi.com</email>
+ <name>Marco Scardovi</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">atom/atom</remote-id>
+ </upstream>
+</pkgmetadata>