aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-01 20:07:02 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2020-05-01 20:14:47 +0200
commitbdfbcde06d84c471e4cf8bcb668e61932aeefb56 (patch)
tree6d7f51b6469e086f58c78744502b79b92acdca3e /app-shells/nice-exit-code
parentapp-shells/zsh-histdb: new package (diff)
downloadguru-bdfbcde06d84c471e4cf8bcb668e61932aeefb56.tar.gz
guru-bdfbcde06d84c471e4cf8bcb668e61932aeefb56.tar.bz2
guru-bdfbcde06d84c471e4cf8bcb668e61932aeefb56.zip
app-shells/nice-exit-code: new package
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'app-shells/nice-exit-code')
-rw-r--r--app-shells/nice-exit-code/Manifest1
-rw-r--r--app-shells/nice-exit-code/metadata.xml12
-rw-r--r--app-shells/nice-exit-code/nice-exit-code-0_pre20200117.ebuild34
3 files changed, 47 insertions, 0 deletions
diff --git a/app-shells/nice-exit-code/Manifest b/app-shells/nice-exit-code/Manifest
new file mode 100644
index 000000000..33594fba9
--- /dev/null
+++ b/app-shells/nice-exit-code/Manifest
@@ -0,0 +1 @@
+DIST nice-exit-code-0_pre20200117.tar.gz 2688 BLAKE2B a67784927f98c0de72e73512eaf032880957e0ec0eaad940c594951bc9e5d898c62350007398e708d0cfc855e3db3046bb481adf867b83dd1a1abf501e3d6888 SHA512 c74a30f28af9ad58b77f470a183006a8fcc4d1f15ba19ce3c2e6ca2e0fd947d25873b36beb86b66bbea97ea1c66b6f088269ca4ab20233b1adea35eb527e5e78
diff --git a/app-shells/nice-exit-code/metadata.xml b/app-shells/nice-exit-code/metadata.xml
new file mode 100644
index 000000000..53ab5fdfa
--- /dev/null
+++ b/app-shells/nice-exit-code/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/bric3/nice-exit-code/issues</bugs-to>
+ <remote-id type="github">bric3/nice-exit-code</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/nice-exit-code/nice-exit-code-0_pre20200117.ebuild b/app-shells/nice-exit-code/nice-exit-code-0_pre20200117.ebuild
new file mode 100644
index 000000000..72da8fb92
--- /dev/null
+++ b/app-shells/nice-exit-code/nice-exit-code-0_pre20200117.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+COMMIT="de7ac733d28705b5e9989b9c8231ac88eb33d841"
+
+DESCRIPTION="ZSH plugin that maps exit status code to human readable string"
+HOMEPAGE="https://github.com/bric3/nice-exit-code"
+SRC_URI="https://github.com/bric3/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+DEPEND=""
+RDEPEND="
+ app-shells/zsh
+"
+
+DOCS=( README.md )
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_install() {
+ einstalldocs
+ rm -rf "LICENSE" "${DOCS[@]}" || die
+ dodir "/usr/share/zsh/plugins"
+ insinto "/usr/share/zsh/plugins/${PN}"
+ doins -r .
+}
+
+pkg_postinst() {
+ einfo "To use this module please read the README"
+}