aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon van der Maas <svdm-gentoo@protonmail.com>2021-02-16 15:20:00 +0100
committerSimon van der Maas <svdm-gentoo@protonmail.com>2021-02-16 15:20:11 +0100
commit8384595045846411fe6ec1cb4f6ee6b8acdd6c69 (patch)
treea3719009ef15880c325783364b3b0ba2fe37ff4e /app-shells
parentmedia-gfx/qview: new package (diff)
downloadguru-8384595045846411fe6ec1cb4f6ee6b8acdd6c69.tar.gz
guru-8384595045846411fe6ec1cb4f6ee6b8acdd6c69.tar.bz2
guru-8384595045846411fe6ec1cb4f6ee6b8acdd6c69.zip
app-shells/zsh-autosuggestions: new package
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Simon van der Maas <svdm-gentoo@protonmail.com>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-autosuggestions/Manifest1
-rw-r--r--app-shells/zsh-autosuggestions/metadata.xml8
-rw-r--r--app-shells/zsh-autosuggestions/zsh-autosuggestions-0.6.4.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/zsh-autosuggestions/Manifest b/app-shells/zsh-autosuggestions/Manifest
new file mode 100644
index 000000000..249800d81
--- /dev/null
+++ b/app-shells/zsh-autosuggestions/Manifest
@@ -0,0 +1 @@
+DIST zsh-autosuggestions-0.6.4.tar.gz 29154 BLAKE2B 73bef916e4abb53f6bd7d8daa67040a78e30aaaf3d71ed04e2f32d4fbbbc35bda1fa8cbcb8957324b52c39bf7ed454132ede657b2caee03798a41a2c330df0d9 SHA512 226b99048577ecdbe198501e6e4b3156c3d849994f0a2f7e15687cd244d4cac472cbcf746aaa32b2886652f6962852a475777b5f2bfcb3a6d0279be98a6020bb
diff --git a/app-shells/zsh-autosuggestions/metadata.xml b/app-shells/zsh-autosuggestions/metadata.xml
new file mode 100644
index 000000000..ad8cead24
--- /dev/null
+++ b/app-shells/zsh-autosuggestions/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>svdm-gentoo@protonmail.com</email>
+ <name>Simon van der Maas</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.6.4.ebuild b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.6.4.ebuild
new file mode 100644
index 000000000..3b307eb01
--- /dev/null
+++ b/app-shells/zsh-autosuggestions/zsh-autosuggestions-0.6.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Fish-like autosuggestions for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-autosuggestions"
+SRC_URI="https://github.com/zsh-users/zsh-autosuggestions/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+DEPEND=">=app-shells/zsh-4.3.11"
+
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/zsh/site-functions/"
+ doins "${PN}.zsh"
+}
+
+pkg_postinst() {
+ elog "In order to use ${CATEGORY}/${PN} add ". /usr/share/zsh/site-functions/zsh-autosuggestions.zsh" at the end of your ~/.zshrc (including the dot)"
+}