aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-02-16 15:03:32 +1300
committerTheo Anderson <telans@posteo.de>2021-02-16 15:03:32 +1300
commit59ec6fd66029c7437ea8ff78b192d8b38a11a829 (patch)
treef68540b0ee33e2f87cef5750b9b7292b1e57107c /app-text
parentdev-python/faker: remove package added to ::gentoo (dev-python/Faker) (diff)
downloadguru-59ec6fd66029c7437ea8ff78b192d8b38a11a829.tar.gz
guru-59ec6fd66029c7437ea8ff78b192d8b38a11a829.tar.bz2
guru-59ec6fd66029c7437ea8ff78b192d8b38a11a829.zip
app-text/OCRmyPDF: bump to 11.6.2
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/OCRmyPDF/Manifest1
-rw-r--r--app-text/OCRmyPDF/OCRmyPDF-11.6.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-text/OCRmyPDF/Manifest b/app-text/OCRmyPDF/Manifest
index ae61fd6be..f904cb5d9 100644
--- a/app-text/OCRmyPDF/Manifest
+++ b/app-text/OCRmyPDF/Manifest
@@ -1,2 +1,3 @@
DIST OCRmyPDF-11.5.0.tar.gz 7884615 BLAKE2B e0b298e011aa648b9d94febbead532d97af510e7281d1d0a8b828843627b9ad326a863e4bc7060a6fd746f114676449ea3575d94d60c30cf08873b06eb31b244 SHA512 e40d28a6b21e729077f34d3e1012965a3f162e4374c0e8c88acc05b143c14626829f25f2c91bb8995aca7609778fac78c91d89c6186109194fc1f211a3462e41
DIST OCRmyPDF-11.6.0.tar.gz 7884950 BLAKE2B 408693ccb73e3c4c0298de27f2c8bff76ca50805a2dc1f84d25e8e5731d31631be238780a8b169d6d42c8a948b58d8708d95b0f0baf30d75deae4e4eac787106 SHA512 d77bbd5adb67a5e354162690665db62cd5baaa6f68443d2303f319d029c0a61b93d9363f5758fabf6d84959a8e07c164be7518f4bcc9f1d4d3408f116bc8caad
+DIST OCRmyPDF-11.6.2.tar.gz 7885633 BLAKE2B a4c09a8088abe3f9e984e8c7ce1b58699c5e40c46de8e9f81ac43838772541758467887b22c3a9fe8026fb8cd125466968e5745af69c9760a0f470879e40685b SHA512 1f92022352b63d2642a0fd49ea72d70973c08d2b2cc84d3d92f06bfd883a858f7dba06f83a921245846d20fc90a1afa0570e7d58fe673e1dfad82e5e047e8de3
diff --git a/app-text/OCRmyPDF/OCRmyPDF-11.6.2.ebuild b/app-text/OCRmyPDF/OCRmyPDF-11.6.2.ebuild
new file mode 100644
index 000000000..ed5786c97
--- /dev/null
+++ b/app-text/OCRmyPDF/OCRmyPDF-11.6.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="OCRmyPDF adds an OCR text layer to scanned PDF files"
+HOMEPAGE="https://github.com/jbarlow83/OCRmyPDF"
+SRC_URI="https://github.com/jbarlow83/OCRmyPDF/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# This uses *a lot* of RAM, I have 32gb and these tests tried to use it all
+RESTRICT="test"
+IUSE="jbig2enc"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/tesseract
+ app-text/unpaper
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ >=dev-python/pdfminer-six-20191110[${PYTHON_USEDEP}]
+ <=dev-python/pdfminer-six-20201018[${PYTHON_USEDEP}]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ media-gfx/img2pdf[${PYTHON_USEDEP}]
+ media-gfx/pngquant
+ media-libs/leptonica
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ jbig2enc? ( media-libs/jbig2enc )
+"
+DEPEND="
+ test? (
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ~dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp misc/completion/ocrmypdf.bash "${PN,,}"
+ insinto /usr/share/fish/vendor_completions.d
+ doins misc/completion/ocrmypdf.fish
+}