aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-26 21:41:36 +1300
committerTheo Anderson <telans@posteo.de>2020-12-26 22:09:38 +1300
commit61f2aae7af18c4a89ff7a1ec525c9d67abbabdab (patch)
tree6a2277052a76729083eec8725d3f6747258e1de7 /app-text
parentapp-misc/navi: bump to 2.13.1 (diff)
downloadguru-61f2aae7af18c4a89ff7a1ec525c9d67abbabdab.tar.gz
guru-61f2aae7af18c4a89ff7a1ec525c9d67abbabdab.tar.bz2
guru-61f2aae7af18c4a89ff7a1ec525c9d67abbabdab.zip
app-text/OCRmyPDF: bump to 11.4.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/OCRmyPDF/Manifest1
-rw-r--r--app-text/OCRmyPDF/OCRmyPDF-11.4.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-text/OCRmyPDF/Manifest b/app-text/OCRmyPDF/Manifest
index 14db1f0dc..3e241f2b2 100644
--- a/app-text/OCRmyPDF/Manifest
+++ b/app-text/OCRmyPDF/Manifest
@@ -1 +1,2 @@
DIST OCRmyPDF-11.4.0.tar.gz 7880918 BLAKE2B 2031a0d8f5676d84be7e4d52a2b8457143dfb85248bc925d452ebe652190da0f34a464478a9cda8ed0650eeb5db5019f83530ea0b74b57079e1cab0e43a20b16 SHA512 f6ed03eacf3dd0aa554841b70e6b2fbb8a7cc7854723a4fb0a52b7b3fcf26387f9bb60b9db57f67af53a979edc66666a3dadbdd10c20fbb375cfaf46339e6737
+DIST OCRmyPDF-11.4.1.tar.gz 7880882 BLAKE2B 80bcce4775e9192cc23f0b9ed0ba8fcbb4b585c628b796f69b60d2e84bcf8157812cf5fa769688af1e71626d41ba249d56ac5cc6bcf4f4fc3a60fa4b5809320b SHA512 bd27d66b24b63584d1945fd29b08e4d8dcffd989b7285ec0d94559514da676cbb7cd6910453d553f859d501ce5a10bb90554574f0e435bbf6d4037d89d0dd4aa
diff --git a/app-text/OCRmyPDF/OCRmyPDF-11.4.1.ebuild b/app-text/OCRmyPDF/OCRmyPDF-11.4.1.ebuild
new file mode 100644
index 000000000..ce3eb17db
--- /dev/null
+++ b/app-text/OCRmyPDF/OCRmyPDF-11.4.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="OCRmyPDF adds an OCR text layer to scanned PDF files"
+HOMEPAGE="https://github.com/jbarlow83/OCRmyPDF"
+MY_GITHUB_AUTHOR="jbarlow83"
+SRC_URI="https://github.com/${MY_GITHUB_AUTHOR}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# This uses *a lot* of RAM, I have 32gb and these tests tried to use it all
+RESTRICT="test"
+IUSE="jbig2enc"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/tesseract
+ app-text/unpaper
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/coloredlogs[${PYTHON_USEDEP}]
+ >=dev-python/pdfminer-six-20191110[${PYTHON_USEDEP}]
+ <=dev-python/pdfminer-six-20201018[${PYTHON_USEDEP}]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ jbig2enc? ( media-libs/jbig2enc )
+ media-gfx/img2pdf[${PYTHON_USEDEP}]
+ media-gfx/pngquant
+ media-libs/leptonica
+ virtual/python-cffi[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ ~dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc
+
+python_prepare_all() {
+ # do not depend on deprecated dep
+ sed -i -e '/pytest-runner/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp "${S}"/misc/completion/ocrmypdf.bash "${PN,,}"
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins "${S}"/misc/completion/ocrmypdf.fish
+}