aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2023-08-04 16:42:11 +0200
committerDavid Roman <davidroman96@gmail.com>2023-08-04 16:42:11 +0200
commit0445e76005acd466feae9320fdd455c4958ae8cf (patch)
tree9966482988c12f5884eed1c5f8de7e76a2d38850 /dev-R/Rcpp/Rcpp-1.0.11.ebuild
parentwww-apps/pleroma: add 2.5.3, drop 2.5.2 (diff)
downloadguru-0445e76005acd466feae9320fdd455c4958ae8cf.tar.gz
guru-0445e76005acd466feae9320fdd455c4958ae8cf.tar.bz2
guru-0445e76005acd466feae9320fdd455c4958ae8cf.zip
dev-R/Rcpp: add 1.0.11, drop 1.0.8.3
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-R/Rcpp/Rcpp-1.0.11.ebuild')
-rw-r--r--dev-R/Rcpp/Rcpp-1.0.11.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-R/Rcpp/Rcpp-1.0.11.ebuild b/dev-R/Rcpp/Rcpp-1.0.11.ebuild
new file mode 100644
index 000000000..70f9a5eb4
--- /dev/null
+++ b/dev-R/Rcpp/Rcpp-1.0.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit R-packages
+
+DESCRIPTION='Seamless R and C++ Integration'
+HOMEPAGE="
+ https://www.rcpp.org
+ http://dirk.eddelbuettel.com/code/rcpp.html
+ https://github.com/RcppCore/Rcpp
+ https://cran.r-project.org/package=Rcpp
+"
+
+LICENSE='GPL-2+ Boost-1.0'
+KEYWORDS="~amd64"
+IUSE="examples"
+
+src_prepare() {
+ if ! use examples ; then
+ rm -r inst/examples || die
+ fi
+ rm -r inst/tinytest || die
+ R-packages_src_prepare
+}
+
+SUGGESTED_PACKAGES="
+ dev-R/tinytest
+ dev-R/inline
+ dev-R/rbenchmark
+ >=dev-R/pkgKitten-0.1.2
+"