aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-08-15 08:48:35 +0200
committerKurt Kanzenbach <kurt@kmk-computers.de>2020-08-15 08:48:35 +0200
commit59bc932e4b3011d0ddc09ea71b581dbd1aac6133 (patch)
treee8e8c423818d95b3d767caf93276eae3340fac4e /dev-embedded/rauc/rauc-1.4.ebuild
parentapp-admin/customrescuecd-x86: initial ebuild (diff)
downloadguru-59bc932e4b3011d0ddc09ea71b581dbd1aac6133.tar.gz
guru-59bc932e4b3011d0ddc09ea71b581dbd1aac6133.tar.bz2
guru-59bc932e4b3011d0ddc09ea71b581dbd1aac6133.zip
dev-embedded/rauc: Bump version
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Diffstat (limited to 'dev-embedded/rauc/rauc-1.4.ebuild')
-rw-r--r--dev-embedded/rauc/rauc-1.4.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-embedded/rauc/rauc-1.4.ebuild b/dev-embedded/rauc/rauc-1.4.ebuild
new file mode 100644
index 000000000..817248224
--- /dev/null
+++ b/dev-embedded/rauc/rauc-1.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOCBUILDER="sphinx"
+DOCDIR="${S}/docs"
+
+inherit autotools docs
+
+DESCRIPTION="Lightweight update client that runs on your Embedded Linux device"
+HOMEPAGE="https://rauc.io/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="json network service test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+ test? ( sys-fs/squashfs-tools )
+"
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/openssl:0=
+ json? ( dev-libs/json-glib )
+ network? ( net-misc/curl )
+ service? ( sys-apps/dbus )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${P}-tests.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable json)
+ $(use_enable network)
+ $(use_enable service)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+ docs_compile
+}