aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-04-29 11:58:31 +0900
committerWilliam Breathitt Gray <vilhelm.gray@gmail.com>2019-04-29 12:00:09 +0900
commit632a6d2d292602425035c47bd31f6b76a0857404 (patch)
tree14fd2e689e12cb8fd18868344791436ccd8d4003 /dev-lang/fbc
parentdev-lang/fbc: Remove proxy maintainer info from metadata file (diff)
downloadguru-632a6d2d292602425035c47bd31f6b76a0857404.tar.gz
guru-632a6d2d292602425035c47bd31f6b76a0857404.tar.bz2
guru-632a6d2d292602425035c47bd31f6b76a0857404.zip
dev-lang/fbc: Simplify definition of xcflags and fblflags
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Diffstat (limited to 'dev-lang/fbc')
-rw-r--r--dev-lang/fbc/fbc-1.06.0.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-lang/fbc/fbc-1.06.0.ebuild b/dev-lang/fbc/fbc-1.06.0.ebuild
index 8783039a0..ba5b069dd 100644
--- a/dev-lang/fbc/fbc-1.06.0.ebuild
+++ b/dev-lang/fbc/fbc-1.06.0.ebuild
@@ -69,10 +69,12 @@ src_compile() {
cd "${S}" || die "cd failed"
fi
- local xcflags=$(usex gpm "" "-DDISABLE_GPM")
- xcflags+=$(usex libffi "" " -DDISABLE_FFI")
- xcflags+=$(usex opengl "" " -DDISABLE_OPENGL")
- xcflags+=$(usex X "" " -DDISABLE_X11")
+ local xcflags=(
+ $(usex gpm "" "-DDISABLE_GPM")
+ $(usex libffi "" " -DDISABLE_FFI")
+ $(usex opengl "" " -DDISABLE_OPENGL")
+ $(usex X "" " -DDISABLE_X11")
+ )
# fbc automatically strips the executables it compiles; in order to avoid
# creating striped executables, we override the fbc hardcoded linker "-s"
@@ -81,10 +83,10 @@ src_compile() {
# "--strip-debug" flag should be a safe option)
local fblflags="-Wl --strip-debug "
# fbc requires a space after the -Wl option
- fblflags+=$(echo "${LDFLAGS}" | sed 's/-Wl,/-Wl /g')
+ fblflags+=${LDFLAGS//-Wl,/-Wl }
# Build fbc
- emake CFLAGS="${CFLAGS} ${xcflags}" FBC="${fbc}" FBCFLAGS="${fbcflags}" FBLFLAGS="${fblflags}"
+ emake CFLAGS="${CFLAGS} ${xcflags[@]}" FBC="${fbc}" FBCFLAGS="${fbcflags}" FBLFLAGS="${fblflags}"
}
src_install() {