aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-01 11:30:19 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-01 11:30:19 +0200
commit339d88a47c4dd7fc0adcbf333bafac6555118a82 (patch)
tree80f2229968266e5c7ba17562a2e51248968be073 /dev-libs
parentdev-cpp/usockets: fixup use flag not in iuse error (diff)
downloadguru-339d88a47c4dd7fc0adcbf333bafac6555118a82.tar.gz
guru-339d88a47c4dd7fc0adcbf333bafac6555118a82.tar.bz2
guru-339d88a47c4dd7fc0adcbf333bafac6555118a82.zip
dev-libs/octetos-core: many fixes
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/octetos-core/octetos-core-1.2.2_beta.ebuild25
-rw-r--r--dev-libs/octetos-core/octetos-core-2.0.0_beta.ebuild23
-rw-r--r--dev-libs/octetos-core/octetos-core-2.2.0_beta.ebuild23
3 files changed, 55 insertions, 16 deletions
diff --git a/dev-libs/octetos-core/octetos-core-1.2.2_beta.ebuild b/dev-libs/octetos-core/octetos-core-1.2.2_beta.ebuild
index 02cfe7dad..6b9289ee4 100644
--- a/dev-libs/octetos-core/octetos-core-1.2.2_beta.ebuild
+++ b/dev-libs/octetos-core/octetos-core-1.2.2_beta.ebuild
@@ -2,24 +2,37 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DESCRIPTION="C/C++ library to mainly provide Semantic Versioned inplmetation."
+
+inherit autotools
+
+DESCRIPTION="C/C++ library to mainly provide Semantic Versioned implementation"
HOMEPAGE="https://github.com/azaeldevel/octetos-core"
SRC_URI="https://github.com/azaeldevel/octetos-core/archive/1.2.2-br.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
+
IUSE=""
+
DEPEND=""
RDEPEND="${DEPEND}"
-BDEPEND="dev-util/cunit >=sys-devel/gcc-8.1 >=sys-devel/bison-3.1"
+BDEPEND="
+ dev-util/cunit
+ >=sys-devel/gcc-8.1
+ >=sys-devel/bison-3.1
+ dev-libs/libconfig
+"
+
src_unpack() {
- unpack ${A}
- ln -s octetos-core-1.2.2-br $P
- #echo "PWD:$PWD"
+ default
+ ln -s octetos-core-1.2.2-br "${P}"
}
+
src_configure() {
-autoreconf -fi
+ eautoreconf -fi
}
+
src_compile() {
if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
emake || die "emake failed"
diff --git a/dev-libs/octetos-core/octetos-core-2.0.0_beta.ebuild b/dev-libs/octetos-core/octetos-core-2.0.0_beta.ebuild
index 74fa4d5bd..76c32d5f1 100644
--- a/dev-libs/octetos-core/octetos-core-2.0.0_beta.ebuild
+++ b/dev-libs/octetos-core/octetos-core-2.0.0_beta.ebuild
@@ -2,25 +2,38 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DESCRIPTION="C/C++ library to mainly provide Semantic Versioned inplmetation."
+
+inherit autotools
+
+DESCRIPTION="C/C++ library to mainly provide Semantic Versioned implementation"
HOMEPAGE="https://github.com/azaeldevel/octetos-core"
SRC_URI="https://github.com/azaeldevel/octetos-core/archive/2.0.0-alpha.2.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
+
IUSE=""
+
DEPEND=""
RDEPEND="${DEPEND}"
-BDEPEND="dev-util/cunit >=sys-devel/gcc-8.1 >=sys-devel/bison-3.1"
+BDEPEND="
+ dev-util/cunit
+ >=sys-devel/gcc-8.1
+ >=sys-devel/bison-3.1
+ dev-libs/libconfig
+"
src_unpack() {
- unpack ${A}
- ln -s octetos-core-2.0.0-alpha.2 $P
+ default
+ ln -s octetos-core-2.0.0-alpha.2 "${P}"
}
+
src_prepare() {
- autoreconf -fi
+ eautoreconf -fi
eapply_user
}
+
src_configure() {
if [[ -x ${ECONF_SOURCE:-.}/configure ]] ; then
econf
diff --git a/dev-libs/octetos-core/octetos-core-2.2.0_beta.ebuild b/dev-libs/octetos-core/octetos-core-2.2.0_beta.ebuild
index 3cd840de0..380bac21a 100644
--- a/dev-libs/octetos-core/octetos-core-2.2.0_beta.ebuild
+++ b/dev-libs/octetos-core/octetos-core-2.2.0_beta.ebuild
@@ -2,30 +2,43 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-DESCRIPTION="C/C++ library to mainly provide Semantic Versioned inplmetation."
+
+inherit autotools
+
+DESCRIPTION="C/C++ library to mainly provide Semantic Versioned implementation"
HOMEPAGE="https://github.com/azaeldevel/octetos-core"
SRC_URI="https://github.com/azaeldevel/octetos-core/archive/2.2.0-beta.3.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
+
IUSE=""
+
DEPEND=""
RDEPEND="${DEPEND}"
-BDEPEND=">=sys-devel/gcc-8.1 >=sys-devel/bison-3.1"
+BDEPEND="
+ >=sys-devel/gcc-8.1
+ >=sys-devel/bison-3.1
+ dev-libs/libconfig
+"
src_unpack() {
- unpack ${A}
- ln -s octetos-core-2.2.0-beta.3 $P
+ default
+ ln -s octetos-core-2.2.0-beta.3 "${P}"
}
+
src_prepare() {
- autoreconf -fi
+ eautoreconf -fi
eapply_user
}
+
src_configure() {
if [[ -x ${ECONF_SOURCE:-.}/configure ]] ; then
econf
fi
}
+
src_compile() {
if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
emake || die "emake failed"