aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-14 03:11:15 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-14 03:41:40 +0100
commitada247acfc32346d56cba11f5f2c92a6ef2799b2 (patch)
tree6c6c3dfda8fc60e5e178b83bae1ebf48119fcbc3 /dev-python/SQLAlchemy-Utils
parentdev-python/ttfautohint-py: add 0.5.1 (diff)
downloadguru-ada247acfc32346d56cba11f5f2c92a6ef2799b2.tar.gz
guru-ada247acfc32346d56cba11f5f2c92a6ef2799b2.tar.bz2
guru-ada247acfc32346d56cba11f5f2c92a6ef2799b2.zip
dev-python/SQLAlchemy-Utils: add 0.38.2
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/SQLAlchemy-Utils')
-rw-r--r--dev-python/SQLAlchemy-Utils/Manifest1
-rw-r--r--dev-python/SQLAlchemy-Utils/SQLAlchemy-Utils-0.38.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/SQLAlchemy-Utils/Manifest b/dev-python/SQLAlchemy-Utils/Manifest
index 240fe11f1..8ea838e16 100644
--- a/dev-python/SQLAlchemy-Utils/Manifest
+++ b/dev-python/SQLAlchemy-Utils/Manifest
@@ -1 +1,2 @@
DIST SQLAlchemy-Utils-0.37.9.tar.gz 136639 BLAKE2B e9e92b185ff45cfee5b1a6e59e78ae819ef15e419e178e8773f6f76d0681e6c047b8124c17b95e49c0a1badff13f27c3718d0f68f67523eabe6333a665d5a134 SHA512 5186ea01d5fab000b79496a501321846b326336cb1e725520acd4512e2d129e51b8887d95f3ca6109575b1263fde0178a84ca7d37da06d8b410bc97649c76f14
+DIST SQLAlchemy-Utils-0.38.2.tar.gz 136800 BLAKE2B 13d1470c65a6eeb198d6846a85f4b9d0a1476fd95eed24d1a06ff3cc9a87fb56243f39bd6b542b7e5749551270e03d8345f5a3da5a1f1e548cfe757c81b26d49 SHA512 2dc98549501e3b8fc3ad77aa14f31940e9aa73999d699bb1a2d4be424eb3bff38a3fc8cacf8774e42f816c1b31cc1ccc4e9955cf1dae2fd3a2b9e4e0f0b18cc7
diff --git a/dev-python/SQLAlchemy-Utils/SQLAlchemy-Utils-0.38.2.ebuild b/dev-python/SQLAlchemy-Utils/SQLAlchemy-Utils-0.38.2.ebuild
new file mode 100644
index 000000000..942071a60
--- /dev/null
+++ b/dev-python/SQLAlchemy-Utils/SQLAlchemy-Utils-0.38.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EPYTEST_DESELECT=( tests/types/test_timezone.py ) # https://bugs.gentoo.org/819021
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Various utility functions and datatypes for SQLAlchemy"
+HOMEPAGE="
+ https://github.com/kvesteri/sqlalchemy-utils
+ https://pypi.org/project/SQLAlchemy-Utils/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ >=dev-python/pygments-2.7.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/flexmock-0.9.7[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg2cffi-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/pg8000-1.12.4[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2014.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.6[${PYTHON_USEDEP}]
+ dev-python/pymysql[${PYTHON_USEDEP}]
+ dev-python/pyodbc[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest