aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-04-28 14:20:50 +1200
committerTheo Anderson <telans@posteo.de>2021-04-28 14:20:50 +1200
commitf7d5468bb22f994f77160b64eb1528d8629ae47a (patch)
treed91ea6d7881392283685e745023e22411d739461 /dev-python/aiosqlite
parentdev-python/aiopg: add 1.2.1 (diff)
downloadguru-f7d5468bb22f994f77160b64eb1528d8629ae47a.tar.gz
guru-f7d5468bb22f994f77160b64eb1528d8629ae47a.tar.bz2
guru-f7d5468bb22f994f77160b64eb1528d8629ae47a.zip
dev-python/aiosqlite: add 0.17.0
Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'dev-python/aiosqlite')
-rw-r--r--dev-python/aiosqlite/Manifest1
-rw-r--r--dev-python/aiosqlite/aiosqlite-0.17.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/aiosqlite/Manifest b/dev-python/aiosqlite/Manifest
index 9f0d74931..442711215 100644
--- a/dev-python/aiosqlite/Manifest
+++ b/dev-python/aiosqlite/Manifest
@@ -1 +1,2 @@
DIST aiosqlite-0.16.0.tar.gz 25690 BLAKE2B be06e8ebea9f3e0c16649fbaaf86317584bd6329e5d890aa3cac432d54122c5441461a40f3690e59453a573bffc56277338391b466abaf121a28c2d71929687c SHA512 f554293663b15303f0aea0d1c10730d15766a30efa0538501a4f08acaccf8807bad78382d5c8a034cdffcfbceb42cbbe4eecdb97e2ef97c5143ab374e9b314b4
+DIST aiosqlite-0.17.0.tar.gz 25941 BLAKE2B 869d165bc8c791cb94159f6508f5113d915f5531117d0d79ac1f297de16cbb78574a7eaafc1bceccc9e4397f88f490b90d49becb4b7cc2c0d51e14f0afd7561b SHA512 50f9965ef7dafe91a2f41dc41489395e437080aa4b7853800d806d21f4f8042d92ff6cfd2aeadefa7ca5e4debd14f39d93ca28c89f3116b3b61b2e8829533e6e
diff --git a/dev-python/aiosqlite/aiosqlite-0.17.0.ebuild b/dev-python/aiosqlite/aiosqlite-0.17.0.ebuild
new file mode 100644
index 000000000..0bd4cb0a5
--- /dev/null
+++ b/dev-python/aiosqlite/aiosqlite-0.17.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio bridge to the standard sqlite3 module"
+HOMEPAGE="https://github.com/jreese/aiosqlite"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? (
+ dev-python/aiounittest[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests unittest
+# TypeError: add_source_parser() takes 2 positional arguments but 3 were given
+#distutils_enable_sphinx docs