aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-01-23 01:05:39 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-01-23 01:05:39 +0100
commitf84ec554bdc36393f377849cf009e27a8ba3c900 (patch)
tree0eb603fba52b367f8864e55b15c671cfc259ad77 /dev-python/automaton
parentdev-python/ldappool: new version (diff)
downloadguru-f84ec554bdc36393f377849cf009e27a8ba3c900.tar.gz
guru-f84ec554bdc36393f377849cf009e27a8ba3c900.tar.bz2
guru-f84ec554bdc36393f377849cf009e27a8ba3c900.zip
dev-python/automaton: new version
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/automaton')
-rw-r--r--dev-python/automaton/Manifest2
-rw-r--r--dev-python/automaton/automaton-2.2.0.ebuild28
-rw-r--r--dev-python/automaton/automaton-2.4.0.ebuild34
3 files changed, 35 insertions, 29 deletions
diff --git a/dev-python/automaton/Manifest b/dev-python/automaton/Manifest
index 46260e7a6..5f52bb278 100644
--- a/dev-python/automaton/Manifest
+++ b/dev-python/automaton/Manifest
@@ -1 +1 @@
-DIST automaton-2.2.0.tar.gz 31629 BLAKE2B 1db3968bf2eb3dcec77edd6ca8f7ad6afd16d4e1a23fe3f5520ab78d8b78e817cf9bde14bb008e8740fdbd03e4b871361402283407133def0c15485962a210ce SHA512 9b773ac93f17542800b93e36ca8b42ab522b2fb1c72d36256a62a37463e49e9f299fbdb9d4507b7f2a6cf678bbcd16fc86be9d20720acf0b254e1bacca4c0300
+DIST automaton-2.4.0.tar.gz 34381 BLAKE2B dda40e6e8b5978e808e80a83581b7c101cca2d5abfd9f46388960608979ce44a1a6457e4cdcb7e7b527f3527c83c0db994c8c55908f61bacd5369ef1bce585fa SHA512 e399fd12fd883112d49aff0d092fbc2b51952a24e3b40eae47d0bd7f5e2648689ab76413a2d404ef686ce5622e4661db1beb3e44a690c5c0279b85f69d267ecd
diff --git a/dev-python/automaton/automaton-2.2.0.ebuild b/dev-python/automaton/automaton-2.2.0.ebuild
deleted file mode 100644
index 6c1330df7..000000000
--- a/dev-python/automaton/automaton-2.2.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_8 )
-
-inherit distutils-r1
-
-DESCRIPTION="Friendly state machines for python."
-HOMEPAGE="https://pypi.org/project/automaton/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE=""
-
-DEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
-"
-RDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8.0[${PYTHON_USEDEP}]
-"
diff --git a/dev-python/automaton/automaton-2.4.0.ebuild b/dev-python/automaton/automaton-2.4.0.ebuild
new file mode 100644
index 000000000..dc7a22d3e
--- /dev/null
+++ b/dev-python/automaton/automaton-2.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Friendly state machines for python."
+HOMEPAGE="
+ https://pypi.org/project/automaton
+ https://opendev.org/openstack/automaton
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-3.1.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest