aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2024-04-02 22:32:10 -0400
committerWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2024-04-02 22:40:21 -0400
commit18e8e769661a1b7aef68ace471a1c1322cdf2475 (patch)
tree345ed90be19bb1673157566f6b086bcb62752314 /dev-python/b2sdk
parentdev-python/b2sdk: bump to 2.0.0 (diff)
downloadguru-18e8e769661a1b7aef68ace471a1c1322cdf2475.tar.gz
guru-18e8e769661a1b7aef68ace471a1c1322cdf2475.tar.bz2
guru-18e8e769661a1b7aef68ace471a1c1322cdf2475.zip
dev-python/b2sdk: drop v1.17.2
Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com>
Diffstat (limited to 'dev-python/b2sdk')
-rw-r--r--dev-python/b2sdk/Manifest1
-rw-r--r--dev-python/b2sdk/b2sdk-1.17.2.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/b2sdk/Manifest b/dev-python/b2sdk/Manifest
index e3a93bdf6..497a680f5 100644
--- a/dev-python/b2sdk/Manifest
+++ b/dev-python/b2sdk/Manifest
@@ -1,3 +1,2 @@
-DIST b2sdk-1.17.2.tar.gz 308753 BLAKE2B 07b6f71f604475d861257a1a7c567fc561a90c1c8c5768d21d63a82ff1c57240a81f8ebf96f1b3113cbea181140a128ebad9ed524e410a9c163a04a1de1ee2a0 SHA512 e618e18de16b021dc86a4b5ee9d315294eba5c3421318a4ea668681dc0420d6c3798f17c17be6475dddad7cfada8bf615916a5dc41ef905b8ecd7623b2a0c7bb
DIST b2sdk-1.21.0.tar.gz 335333 BLAKE2B 7aa3a9664844e1f5ef71b7eec2fc28f456bed0a8ae431a90f23865cb9d73526090f78926b943f67bb1745bb9760718666202a9bd67790d92d90c14a0f1510bab SHA512 3d431ce8a3be536d6e49d20a0e6eef2d435bfccf2dd36c0b501c03ebd013de68063302f3ae4d8c9cd6fcfa7b77e3ea2c00b06c3a5e044e30f545a4ab5248fa62
DIST b2sdk-2.0.0.tar.gz 197178 BLAKE2B b6a394c790a7d04b07fb1a634fa7b2e157e4c59f3652c29e41226670c28e8ca872eb9f2ff883ef4b2bda23fed29b564c33707a9265f90db5faf5587ec9ef2767 SHA512 c767151c8fe10904f79c793e93f9cb54a116462f8fd961b7a1097e820cdf15797dc72b15ce2811a7578ae2d77eddfec1dbf04b14fefd4ce86616595077a5f34e
diff --git a/dev-python/b2sdk/b2sdk-1.17.2.ebuild b/dev-python/b2sdk/b2sdk-1.17.2.ebuild
deleted file mode 100644
index b489c7ec0..000000000
--- a/dev-python/b2sdk/b2sdk-1.17.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_PEP517="setuptools"
-PYTHON_COMPAT=( python3_10 python3_11)
-inherit distutils-r1
-
-DESCRIPTION="The client library for BackBlaze's B2 product"
-HOMEPAGE="https://github.com/Backblaze/b2-sdk-python"
-SRC_URI="https://github.com/Backblaze/b2-sdk-python/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.17.2-disable-requirement-installation.patch"
-)
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/arrow-1.0.2[${PYTHON_USEDEP}]
- >=dev-python/logfury-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
- >=dev-python/tqdm-4.5.0[${PYTHON_USEDEP}]
- ')
-"
-
-distutils_enable_tests pytest
-
-BDEPEND+=" test? (
- $(python_gen_cond_dep '
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-lazy-fixture-0.6.3[${PYTHON_USEDEP}]
- ')
-)"
-
-# These tests seem to require some b2 authentication (they're integration tests
-# so this is not unreasonable)
-python_test() {
- # note: used to avoid an ExcessiveLineLength lint below.
- local sqlite_test_path="test/unit/account_info/test_sqlite_account_info.py"
- epytest \
- --deselect test/integration/test_large_files.py::TestLargeFile::test_large_file \
- --deselect test/integration/test_raw_api.py::test_raw_api \
- --deselect test/integration/test_download.py::TestDownload::test_large_file \
- --deselect test/integration/test_download.py::TestDownload::test_small \
- --deselect test/integration/test_download.py::TestDownload::test_small_unverified \
- --deselect test/integration/test_download.py::TestDownload::test_gzip \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_invalid_profile_name \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_profile_and_file_name_conflict \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_profile_and_env_var_conflict \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_profile_and_xdg_config_env_var \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_profile \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_file_name \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_env_var \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_default_file_if_exists \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_xdg_config_env_var \
- --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_default_file
-}