aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2023-06-04 20:50:25 -0400
committerWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2023-06-04 23:13:16 -0400
commit9e1e844f36e2cca894b35dbe12eb129dd8cbf57d (patch)
tree5ab57cfae7fc21795b94841773489df82354e95e /dev-python/b2sdk
parentnet-misc/xmrig-mo: add 6.19.3 (diff)
downloadguru-9e1e844f36e2cca894b35dbe12eb129dd8cbf57d.tar.gz
guru-9e1e844f36e2cca894b35dbe12eb129dd8cbf57d.tar.bz2
guru-9e1e844f36e2cca894b35dbe12eb129dd8cbf57d.zip
dev-python/b2sdk: Add python 3.11 to PYTHON_COMPAT
Also address a few pkcheck scan lints Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com>
Diffstat (limited to 'dev-python/b2sdk')
-rw-r--r--dev-python/b2sdk/b2sdk-1.17.2.ebuild25
-rw-r--r--dev-python/b2sdk/metadata.xml3
2 files changed, 17 insertions, 11 deletions
diff --git a/dev-python/b2sdk/b2sdk-1.17.2.ebuild b/dev-python/b2sdk/b2sdk-1.17.2.ebuild
index a99cc31eb..b489c7ec0 100644
--- a/dev-python/b2sdk/b2sdk-1.17.2.ebuild
+++ b/dev-python/b2sdk/b2sdk-1.17.2.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_10 )
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_10 python3_11)
inherit distutils-r1
DESCRIPTION="The client library for BackBlaze's B2 product"
@@ -39,6 +40,8 @@ BDEPEND+=" test? (
# These tests seem to require some b2 authentication (they're integration tests
# so this is not unreasonable)
python_test() {
+ # note: used to avoid an ExcessiveLineLength lint below.
+ local sqlite_test_path="test/unit/account_info/test_sqlite_account_info.py"
epytest \
--deselect test/integration/test_large_files.py::TestLargeFile::test_large_file \
--deselect test/integration/test_raw_api.py::test_raw_api \
@@ -46,14 +49,14 @@ python_test() {
--deselect test/integration/test_download.py::TestDownload::test_small \
--deselect test/integration/test_download.py::TestDownload::test_small_unverified \
--deselect test/integration/test_download.py::TestDownload::test_gzip \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_invalid_profile_name \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_profile_and_file_name_conflict \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_profile_and_env_var_conflict \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_profile_and_xdg_config_env_var \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_profile \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_file_name \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_env_var \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_default_file_if_exists \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_xdg_config_env_var \
- --deselect test/unit/account_info/test_sqlite_account_info.py::TestSqliteAccountProfileFileLocation::test_default_file
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_invalid_profile_name \
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_profile_and_file_name_conflict \
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_profile_and_env_var_conflict \
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_profile_and_xdg_config_env_var \
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_profile \
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_file_name \
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_env_var \
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_default_file_if_exists \
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_xdg_config_env_var \
+ --deselect ${sqlite_test_path}::TestSqliteAccountProfileFileLocation::test_default_file
}
diff --git a/dev-python/b2sdk/metadata.xml b/dev-python/b2sdk/metadata.xml
index 917b9a52a..5cdee8c4c 100644
--- a/dev-python/b2sdk/metadata.xml
+++ b/dev-python/b2sdk/metadata.xml
@@ -11,4 +11,7 @@
This program provides command-line access to the B2 service.
</longdescription>
+ <upstream>
+ <remote-id type="github">Backblaze/b2-sdk-python</remote-id>
+ </upstream>
</pkgmetadata>